Upfront/Spirit questions and issues

HI,
I'm finally getting some results from Upfront in building my site. Unfortunately it's not as easy as I had hoped. (A reminder...I'm a novice.) I have several questions and observations so far. I hope it is okay to put them all into one post.

1. How can I get rid of the padding/margin around my header logo image? I want the top and bottom to be flush with the top and bottom edge of the background. There is no space on the original Image so I can't see why it doesn't work. I've attached some images to demonstrate.
A- this is what I get in upfront
B- this is what I want.

2. I get a script warning everytime I "undo" or do anything that seems to require a script...what ever that is. See the "script warning" image.

3. Whenever I edit a region, on saving, it places a huge white space between that region and the one above it. I found that if I go back to the top region, choose to edit it but don't make any changes, then save and go back then the white space is gone. This happens every time and it's really annoying. See the "editing regions" image.

4. What I'm seeing in the Editor is not what I'm seeing on the actual site. Take a look at the image "In Upfront" and then the image "Actual Site". The yellow region that says "Where All The....etc" is taller than in the editor. How can I keep the propotions I have in the editor?

5. Finally (for this round), how can I change the font in the navigation bar? I can't seem to find where that can be done.

Wait...one more thing... (6) Where is the page that I'm showing as my samples. I'm thinking this is the home page but when I go to the WP dashboard, not a one of those pages shows the page I created in Upfront. Where on earth (0r in cyberspace) is that page in the WP listing? Every page I look at is the Spirit template. Yet if I go to the site that page is there as the landing page.

Oh...one more (7) It looks like the Popup Pro may not be compatible with this. I got a weird message about "popup" when I opened Upfront and when I disabled the plug in the message went away. Can you verify that it's good to go? Popup Pro is critical to how my site will work. See Popup warning.

On a brighter note. I'm very grateful for the new Manager plugin that let me easily reset the theme back to the original state. That was very helpful and actually helped me make some progress.

  • Anang

    Hi Terry

    Sorry for delay..

    1. Upfront have some padding region element, and there's also min-height attribut that need to overridden. You can add css below in Upfront global css

    .upfront #upfront-region-region-15,.upfront #module-1440102595433-1405,.upfront #image-1440102595427-1620{
    min-height:360px !important;
    }
    .upfront div#image-1440102595427-1620{
    padding:0 15px;
    }

    See global-custom-css screenshot to find where to put it.

    2. I get a script warning everytime I "undo" or do anything that seems to require a script...what ever that is. See the "script warning" image.

    I don't get that errors, maybe it's depend on your browser and operating system and computer spec. But I confirmed there's a javascript errors that may causing script not responsive. It's your Creative Slider that causing javascript errors. You may want to change to other sliders to prevent this errors to showed up again :slight_smile: See screenshot creative-slider.png

    3. Whenever I edit a region, on saving, it places a huge white space between that region and the one above it. I found that if I go back to the top region, choose to edit it but don't make any changes, then save and go back then the white space is gone.

    I don't get this issues on my side, what browser and OS are you using ? I'm using chrome in Windows 7. Please advise :slight_smile:

    4. What I'm seeing in the Editor is not what I'm seeing on the actual site. Take a look at the image "In Upfront" and then the image "Actual Site". The yellow region that says "Where All The....etc" is taller than in the editor. How can I keep the propotions I have in the editor?

    As I mentioned before, Upfront have 15px padding by default, so it will always higher on the live than editor, you can override this by css on Upfront global css :slight_smile:

    .upfront-output-object{
     padding:0px 15px !important;
    }

    5. Finally (for this round), how can I change the font in the navigation bar? I can't seem to find where that can be done.

    You can click green gear icon, to popup nav settings. And you can click edit icon for main-nav. Please see edit-nav-style.png screenshot.

    (6) Where is the page that I'm showing as my samples. I'm thinking this is the home page but when I go to the WP dashboard, not a one of those pages shows the page I created in Upfront. Where on earth (0r in cyberspace) is that page in the WP listing? Every page I look at is the Spirit template. Yet if I go to the site that page is there as the landing page.

    Unfortunately the Upfront home page is completely virtual, you can't find it in Wordpress Dashboard :slight_smile: Currently no workaround for this issue :slight_smile:

    (7) It looks like the Popup Pro may not be compatible with this. I got a weird message about "popup" when I opened Upfront and when I disabled the plug in the message went away. Can you verify that it's good to go? Popup Pro is critical to how my site will work. See Popup warning.

    I can confirm Popup Pro is working along with Upfront, I have it on my installation and works great :slight_smile: Maybe your errors from Creative Slider prevent Popup Pro to works properly :slight_smile:

    There's a longest post I have for today lol

    Let me know if you have any questions else :slight_smile:

    Best Regards

  • Terry

    Anang,
    #1. That solution worked.

    #2. The script error seems to be happening in Frirefox (40.0.2). I do not get the error message in Safari or Chrome. I deactivated the slider and still get the error mesage in Firefox. I hope I can keep the slider because it's the only one I've found that does what I want (a contiuous carousel of images). But, I tried loading in the slider from Chrome and Safari and it was taking so long to load I gave up on that. None-the-less. The script error still appears in Firefox with undos. I'm on Mac 10.9.5 by the way.

    #3. The extra white space seems to come and go. It appears that an "undo" triggers the event. I tried it in all three browsers. If I just go in and "edit" and then "finish editing" the region everything is okay. If I edit something in an element (move one for example) and "undo" , If I then edit a region (without doing any real editing) and then "finishing editing", the white space appears.

    #4. The code for this didn't work for me. Although I may not have placed it correctly. I just added it under the first code you gave me. Was that correct?

    #5. Got that to work. Am I correct that I have to use this same editing to change the hover and drop-down color?

    #6. Well, I guess that has to be okay. Is there a way to easliy get the navigation and footer to carry through to the other pages?

    #7. Happy to hear about Popup Pro being compatible.

    Thanks Anang for your patience and help. I'm very gateful. I know this was a long message. Would it be better for me to break the questions up into indvidual or, at least, smaller posts? I'm afraid I'm going to have a lot of questions in the weeks to come.

    Terry

  • Anang

    Hi Terry

    Thanks for the access :slight_smile:

    #2. The script error seems to be happening in Frirefox (40.0.2). I do not get the error message in Safari or Chrome. I deactivated the slider and still get the error mesage in Firefox. I hope I can keep the slider because it's the only one I've found that does what I want (a contiuous carousel of images). But, I tried loading in the slider from Chrome and Safari and it was taking so long to load I gave up on that. None-the-less. The script error still appears in Firefox with undos. I'm on Mac 10.9.5 by the way.

    I checked on my Firefox in Windows, but still didn't get the error, I will try on my mac later to confirm this issues, I'm bringing my windows laptop now :slight_smile: And I will update you what I got there :slight_smile:

    #3. The extra white space seems to come and go. It appears that an "undo" triggers the event. I tried it in all three browsers. If I just go in and "edit" and then "finish editing" the region everything is okay. If I edit something in an element (move one for example) and "undo" , If I then edit a region (without doing any real editing) and then "finishing editing", the white space appears.

    I'm trying to reproduce this issues as your instructions above but still no luck too :slight_frown: Could you give me a screencast ? There a free extension for chrome called Screencastify. Would be a great help if you can provide us a screencast :slight_smile:

    #4. The code for this didn't work for me. Although I may not have placed it correctly. I just added it under the first code you gave me. Was that correct?

    Yeah that code is correct and working , but I see there's some extra html paragraph tags there that causing some padding on your element. Could you try delete that element and added it again ?

    #5. Got that to work. Am I correct that I have to use this same editing to change the hover and drop-down color?

    Yes, you're correct :slight_smile: You can change it through css there

    #6. Well, I guess that has to be okay. Is there a way to easliy get the navigation and footer to carry through to the other pages?

    You can set your footer region as global region, that way your footer will apply to all pages on your site. Check this thread, if you have problem to set it as global region : https://premium.wpmudev.org/forums/topic/how-does-the-global-theme-footer

    Would it be better for me to break the questions up into indvidual or, at least, smaller posts? I'm afraid I'm going to have a lot of questions in the weeks to come.

    If your question is still related about issues above, let's continue here for better tracking in the future. But if it's new issue please create a new thread, so you got proper handle about your new issues :slight_smile:

    I'm waiting for your screencast for #3 issue and progress on #4 issue :slight_smile: Have a great day :slight_smile:

    Best Regards

  • Terry

    Anang,
    I wasn't sure the of the best way to send the screen cast so I put it up on my youtube channel.

    https://www.youtube.com/watch?v=NeU-lYIBYwo

    I included the script error also. It only shows up in Firefox. The white space issue is the same for Firefox, Safari and Chrome. For either one, I think I can move on with life since the fix for the white space is simple and the Script error in FIrefox does not keep the undo from happening. On the other hand, with all the testing I did, I think I'll switch to Safari since everything seemed to go a lot faster in that browser.

    For the extra padding on #4, I recopied your code and replaced it in the editor. I still didn't see any change. Can you please show me where the extra padding is?

    For the global navigation and footer. I have both set as global but only the footer carries through to the other pages. The navigation does not. Is there something more to do for that? (sorry to say that the link to the thread for this solution didn't help)

    Thanks!
    Terry

  • Terry

    Just checking to see if were able to see the video? Today the white space is not showing up when I edit a region. But, all of a sudden the navagation bar is yellow and it's supposed to be red. I didn't change anything other than the code we added. How can I get the red nav bar back?
    If we can do that lets call this ticket closed and, for now, I'll live with what I have or start over again. I have granted access to the site.
    I'll submit future issues in separate requests.
    Thanks!
    Terry

  • Tyler Postle

    Hi there Terry,

    Working alongside Anang here.

    Thanks for the video. I'm not able to replicate the white space issue on my install either.

    As for the script error, I am seeing a similar issue in Firefox - reporting this to the developer :slight_smile:

    Then for the menu bar can you add this CSS:

    #page .main-nav ul#menu-yodeling-hall-fame-navigation {
        background: rgba(214,35,48,1);
    }

    Try adding it to this plugin here: https://wordpress.org/plugins/simple-custom-css/ - upon activation you will get a "Custom CSS" field underneath appearance in your WP dashboard.

    Did you add any other custom CSS somewhere? Just trying to find out why that menu changed colour in the first place, very odd!

    Look forward to hearing back.

    All the best,
    Tyler

  • Terry

    Thanks for the reply Tyler. The white space comes and goes. A few days ago it showed up and I couldn't get rid of it. The last time I was in there it never showed up at all no matter what I did. That's a good thing but it sure is strange. As for the rest, I'm going to reset and start all over again. Let's hope the "third time is the charm". I'll post additional questions and issues in separate support requests (yep, there are a number of them). As for adding any custom CSS, I'm using Upfront because you're not supposed to have to know any coding so, no, I've not added anything except what your team has recommended. I'm not a "coder" but am realizing there's no way out. Not one of the so-called "drag and drop" web builders I've tried has lived up to that promise. Most every issue is usually answered by, "you just have to add this code". I'm sticking with Upfront though, mainly because of the very personal support that is offered. Tyler, let's consider this thread closed.
    Thanks!
    Terry

  • Terry

    Should you wish to hear from a guy that is just trying to create a website who craves to share his passion for a subject that means a lot to him. A guy who believes it when a app claims that no coding is needed and you can create the website of your dreams. A guy who is a designer and want's it his way. Only to find out that the answer to every issue is, "oh you just have to enter this code." Well, I'm that guy. I'm not a coder. I'm a dreamer. If you really want the answer to making the best drag and drop solution call me, email me, come visit me. I will tell you what i need. If your product is really only for those who already can do what you offer with their own expertise...well I'm not there.
    So, should you wish to hear from the guy who could give you some valuable feedback into your product. Let me know.

  • Tyler Postle

    Hey Terry,

    Thanks for your reply back.I'll admit that Upfront isn't as ready as we thought it was when we officially launched it. There was some fairly major issues right from the get-go. We've been working on those and have made a lot of progress since the initial release as you may have noticed with the most recent updates. We plan to get to version 1.0 by the end of the year :slight_smile:

    Of course we want to get to that point where custom code really isn't needed at all. Same will go for our Upfront child theme builder that we hope to release by the end of the year as well - then you will be able to create the themes from the ground up instead of altering an existing child theme.

    Anyways I just want to make sure you know that we haven't lost focus on Upfront at all. It is still a major focus here and has more devs working on it than any of our other products.

    As for feedback, that would be really appreciated if you could share your thoughts with us. You could send them to me privately through our contact form: https://premium.wpmudev.org/contact/

    Select "I have a different question" and make the subject line "Attn: Tyler Postle". This ensures it gets assigned to me then I can make sure that our Upfront developers get a chance to read through your feedback as well.

    Thanks for sticking with us on this Terry! Looking forward to seeing what you think as we get closer to v1.0.

    Hope you're enjoying your weekend!

    Cheers,
    Tyler

  • Terry

    Thanks for the reply Tyler. I truly appreciate all of the very personal support that you and everyone else have given. I can say that Upfront is the closest thing I've found yet that is a true "visual" drag and drop. So it's very exciting to see that it at least works in that capacity. I'll keep moving on with trying to make my sight and will let you know if I come up with any issues or comments. I should keep posting basic support questions the normal way. Correct? Anyway, I've been trying to get this site going for some time and it's "now or never" at this point. Being just retired from 40+ years from a job in design and illustration, I have time to try things out. Development was one of the things I loved most about my work, so you will probably be hearing from me if I think I can "help". Honestly, I enjoy being a subscriber to your services and look forward to every Blog post and Whip email. I read all of them even though much of the content is far beyond my basic know-how. But I love to learn new things. Thanks again for your help Tyler.

    Terry

  • Tyler Postle

    No problem at all Terry! We'll get it there :slight_smile:

    I'll keep moving on with trying to make my sight and will let you know if I come up with any issues or comments. I should keep posting basic support questions the normal way. Correct?

    Yes, posting support questions here is the best way. The way our support system works on the backend is that if an issue posted ends up being a bug or something we need to pass onto another staff, we can flag it for them so they are notified. Posting here just makes everything streamlined and ensures we don't miss any tickets.

    Thanks again!

    Honestly, I enjoy being a subscriber to your services and look forward to every Blog post and Whip email. I read all of them even though much of the content is far beyond my basic know-how. But I love to learn new things

    Glad to hear it! We are actually currently planning a WPMU DEV Academy. Where we will have courses on different WP related subjects and you can earn points. It's still just in planning at the moment but it should be cool :slight_smile: we've wanted to do something like this for awhile now but just haven't got around to really planning it until now.

    Cheers,
    Tyler

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.