Upgrade causes error

My client apparently upgraded their MarketPress plugin without telling me and now it's throwing errors. Normally, I wouldn't have them as an admin, but there were issues with this plugin letting them do certain things which could only be resolved by making them an admin, so they had permissions to be able to do the upgrade.

The errors can be seen at:
http://internationaltowingmuseum.org/shop/shopping-cart/

What could have caused that?