"Upgrade Network" Always Present?

Today the "Upgrade Network" function is always highlighted on my network admin screen. I have done some Googling and some people seem to think it's always supposed to be there... but when logging into a subsite as admin, I see that they are also receiving a notification saying "There are pending changes to your account. This message will disappear once these pending changes are completed." That is new, and it shouldn't be there.

It doesn't matter how many times I upgrade the network... the function is always there and the message never goes away. I have done some experimenting with Defender today and only noticed this happening after installing it, but I cannot say Defender has anything to do with it. I got the same issue on a test network, also after installing Defender, but have removed Defender from that test network and the issue persists.

  • Michael Bissett

    Hey William Kowalski, Michael here!

    Today the "Upgrade Network" function is always highlighted on my network admin screen.

    I'd like to see this one in action, could you please enable Support Access to your Multisite?

    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    when logging into a subsite as admin, I see that they are also receiving a notification saying "There are pending changes to your account. This message will disappear once these pending changes are completed."

    That'd be a message from Pro Sites, usually it's not a problem (unless it's always there, then the changes to the account haven't been applied, that'd be a separate matter, though).

    I have done some experimenting with Defender today and only noticed this happening after installing it, but I cannot say Defender has anything to do with it.

    I'm always seeing the "Upgrade Network" menu item present as a item of the "Dashboard" menu in the Network Dashboard, whether Defender is installed, or no. Still curious about the item being highlighted.

    Kind Regards,
    Michael

  • William Kowalski

    Hi Michael,
    Sorry, when I said highlighted, I should have said simply "present". It's not literally highlighted (unless you happen to click on it, in which case it's bolded white.) I thought that the message I was getting on the subsite was related to the Network Upgrade, but if it isn't, I won't worry about it.

    If that option to upgrade the network is always there, are there any best practices for how often one should do it? And does it result in a service disruption for users?
    Thanks

  • Jude

    Hi @williamkowalski

    Sorry about the delay here. I would not worry much about the Network upgrade option. I see it on my network too.

    Its best to do it once each time a new release of WP core is released. It may cause a small downtime for your users, depending on the number of tables on the DB, but this can be bought to almost zero with a good cache + CDN setup for the sites.

    Hope that clarifies

    Cheers
    Jude

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.