Upgrade Notification

I just downloaded the file, yet it's telling me I'm running v 2.2.8 and that I need to upgrade.