Upgrade theme instructions (Studio)

It seems I’m running v 2.1.5 of Studio, even though I first downloaded it in December. Anyway, is there documentation on how to update properly? I do have the theme broken out properly into a parent and child with the child active.



  • Steve McGough
    • Site Builder, Child of Zeus

    OK – I would think that to be the case, but this theme is Studio, and per the instructions is specifically suggests to create a Child Theme for Studio if you plan to make any changes.

    The auto upgrade was not automatic, since it updated the theme and replaced the child with the parent as the active theme. When I switched the theme to the child, the navigation menu went away from the site.

    So I went ahead and did the update via FTP, updating both the parent in full and then uploading the child into the child theme folder.

    Now I have the following errors on the site.

    Warning: Invalid argument supplied for foreach() in /home/devgbd/public_html/wp-content/themes/studio/library/options/options.php on line 7

    Warning: Invalid argument supplied for foreach() in /home/devgbd/public_html/wp-content/themes/studio/library/options/options.php on line 10

    Warning: Invalid argument supplied for foreach() in /home/devgbd/public_html/wp-content/themes/studio/library/options/options.php on line 13

    Fatal error: Call to undefined function font_show() in /home/devgbd/public_html/wp-content/themes/studio/header.php on line 10


  • EnzoMDD
    • Site Builder, Child of Zeus

    Hey @spidercreations,

    Your navigation bar could have gone away as when you change themes it resets your navigation configuration.

    Go to: Appearance > Menus > Theme Locations, and select the menu you want to use from the drop down.

    Do you get any errors when you use the parent theme by itself?

    I think your child theme needs to be updated to be used with the latest version of Studio.

    Place the child theme folder into a zip and attach it here, I can fix the problem for you.

  • Steve McGough
    • Site Builder, Child of Zeus

    Thank you. This time around I made another back up and did the following, which is the same thing that I did before.

    – Used WPMU DEV Dashboard to update the theme from 2.2.0 to 2.2.2.

    – End

    At this point I checked everything and it looked fine and I was running the new version of the theme. Last time, it’s possible I “activated” the parent theme after the upgrade, but I’m pretty certain I did not do that and the parent still became the active theme.

    The real problems occurred when I tried to do it via FTP last time. Since I had created a Child, but made no changes to the Child theme at all, I overwrote both the Parent and the Child with the new 2.2.2 files after I extracted them locally.

    This time it seems to have worked. Thank you for getting back to me overnight, it’s appreciated.


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.