Upgrading Buddypress but not the theme

We're building using WP 3.2.1 with MultiSite and BP 1.2.10 for a large production site. Because of our production timing, I thought I was going to have to commit to BP version 1.2.10 and not be able to upgrade to 1.5.x.

We're trying to get this site open before the end of this month; but now for (mostly) performance issues I am thinking about upgrading to BP 1.5.x at the last minute. Please keep in mind that we have done massive customization to WP core, BP and well over a hundred plugins. (NB: Please do not lecture me about hacking core. This is commerce, and we do what we have to do.... :slight_smile:

So redoing some of this customization would result in huge time and expense. But when I actually sat down to figure out what we would have to do to upgrade to BP 1.5, I realized that we had done relatively little hacking to BP core (this actually surprised me) - almost all the customization was done to to the BP 1.2x default *theme*.

So my question is: Will the BP default 1.2.x theme run on BP 1.5? And if it does, is some specific functionality lost, and if so, what? Or is there such a difference that, even if this works, it would render the advantages of upgrading to 1.5 almost moot? (I know that not all plugins are 1.5 compatible; but that is a separate issue.)

If we could upgrade BP and not the theme that would make this much more doable for us. Right now redoing the changes and customization we made to the BP 1.2 default theme would take us a considerable amount of time.. My thanks for any light you could share on this --

  • Timothy
    • Chief Pigeon

    Please keep in mind that we have done massive customization to WP core, BP and well over a hundred plugins. (NB: Please do not lecture me about hacking core. This is commerce, and we do what we have to do.... :slight_smile:

    Not lecturing, just wondering why you didn't do all the extras through a custom plugin? WP provide a ton of hooks. I just wonder if the changes where that extensive why something like CAKE was not considered instead.

    Just interested :slight_smile:

    So my question is: Will the BP default 1.2.x theme run on BP 1.5? And if it does, is some specific functionality lost, and if so, what? Or is there such a difference that, even if this works, it would render the advantages of upgrading to 1.5 almost moot? (I know that not all plugins are 1.5 compatible; but that is a separate issue.)

    The changes between 1.2 and 1.5 were rather extensive, I have ran a compare myself but I would imaging you will run into some issues trying to use a 1.2 theme on a 1.5 install. That said, the only way to know for sure would be try.

    Usually in these instances I would give it a quick test to see. however my broadband has gone down and I'm connecting through a tethered 3g connection so its all a little slow for me at the moment. Sorry.

    You could take a peek at the changes detailed on the BP site:

    http://buddypress.org/tag/1-5/

    You will not that between 1.2 and 1.5 beta 1 there were 2,161 total code changes.

    Hope some of this helps. :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.