Upgrading BuddyPress from 1.6.2 to 1.6.4 causes pages to be inaccessible

I get an anxiety attack every time I have to upgrade BuddyPress.

When I upgraded from 1.6.2 to 1.6.4 some of my pages became inaccessible. Even if I tried to edit the page and then tried to view it I would get a 'page not available' notice.

I deactivated the upgrade and reinstalled and reactivated the 1.6.2 version and everything was fine.

I am using the Business Portfolio child theme with Membership and BuddyPress.

This error made it impossible for new members to sign up as when they clicked the link the page was not accessible.

How can I fix this?

Thanks,

JoAnn

  • mort3n

    Hi JoAnn,

    Just to add a few questions to the very relevant ones that Ari asked above, could you advice whether you upgraded other plugins at the same time as BP? In particular I'm curious about Membership.

    Also, you say that some of your pages became inaccessible. I read this as meaning 'not all'. If that is correct, then what do the affected pages seem to have in common? If anything. I'm thinking about BP component pages, Membership pages (registration etc.) or pages with a particular functionality embedded.

    Please advice :slight_smile:

    Cheers
    Mort3n

  • JoAnn

    Hi guys, thanks for listening.

    I did not upgrade any other plugins, only the BuddyPress.

    My wordpress version is 3.5.1

    I am using the latest beta Membership plugin 3.4.4

    If I remember correctly the pages that were not available were ones with the membership short code [subscriptionform]

    There may have been other pages, I did not check.

    And, as I said, I was unable to view those pages in any form, even if I opened them up to edit them and then tried to view them.

    If you need more information I can update BuddyPress again to get more information.

    The update did not interfere with the function of the website, but I have a few other glitches with BuddyPress that I thought the update would fix. If not I will post those issues in another topic.

    Thanks,

    JoAnn

  • mort3n

    Hi JoAnn,

    Thanks for your reply.

    This does seem strange indeed.

    You probably did this already, but did you double check the Registration page setting in Membership->Options Membership pages?

    Is the page you embedded the shortcode in also a BP Component page?

    Did you put the shortcode in via the WP editor or a page template?

    If this fails, then try disabling any other plugins you have and activate them one at a time testing to see if any of them is incompatible with the rest of your setup. Similarly, try changing to a standard theme and test for the issue.

    On a different note, you could choose to revert to an officially supported combination of BP and Membership version. A beta is, well, a beta :slight_smile: and the latest release only supports up to BP 1.6.3 according to the Membership plugin page.

    Please advise :slight_smile:

    Cheers
    Mort3n

  • JoAnn

    Hi Ari,

    Yes, this problem was fixed and did not show up again. If I remember correctly is was a temporary glitch with Chrome that eventually worked itself out.

    I opened Internet explorer and make some changes and it was fixed. I really can't remember exactly what I did as it was quite a while ago.

    I apologize for not updating this page at that time.

    Thanks for all the support,

    JoAnn

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.