Upgrading WPMU to WPv3.3

Hi, I have recently set up an WPMU site, hosting with psek. (they were great and actually set up the site.) I currently run 3.0, notice I need to run 3.3 to use the latest version of marketpress. I figured i'm best off to be running the latest from the start.

so...

I have backed up the whole database from Control Panel.

Does the Automatic Update from the dashboard work reliably on MU sites, or is there a better way to handle it.

I don't want to create a tech headache doing a simple updgrade.

Thanks in advance.

Mark

  • Mark de Scande
    • Syntax Hero

    Read this first :slight_smile: https://premium.wpmudev.org/forums/topic/wordpress-33-is-out-heres-what-you-need-to-know

    Some test i always do before upgrade

    1) Make sure you have a backup and DB Backup
    2) Make sure you can add a theme / plug to your MU set up if not add these to your wp-config.php
    define('WP_DEBUG', false);
    define('FS_METHOD', 'direct');
    define('WP_ALLOW_REPAIR', true);
    define('WP_POST_REVISIONS', false );
    define('EMPTY_TRASH_DAYS', 0 ); // zero days
    define('DISABLE_WP_CRON', true);
    define('WP_MEMORY_LIMIT', '128M');

    Now see if you can upload any theme / plug to your MU set up if yes PRESS THE UPGRADE BUTTON :slight_smile:

    If all is ok it should just run trough the process and upgrade your site :slight_smile:

  • Philip John
    • DEV MAN’s Apprentice

    Hiya Mark,

    The automatic upgrade should work fine for ya. It should only take a few minutes.

    Just remember to de-activate all plugins first and revert to the default theme. This helps avoid any conflicts with the upgrade process.

    Also make sure you hit the button to update the network, too. That'll run through each of your sub-sites one after another and update them too.

    Thanks,
    Phil

  • ideastream
    • Flash Drive

    Hi Phil and Mark,

    Thanks for your detailed input guys. Much appreciated.

    Did the process, and all looked like it went smoothly except for 1 line...

    Warning: strpos() [function.strpos]: Empty delimiter in /home/webjv/public_html/wp-includes/user.php on line 699

    After looking at a couple of forum docs, I understand it is a delimiter inconsistency of some sort. The code looks like this - line 699 is in italics (my emphasis):

    foreach ( $keys as $key ) {
    if ( 'capabilities' !== substr( $key, -12 ) )
    continue;
    if ( 0 !== strpos( $key, $wpdb->base_prefix ) ) continue;
    $blog_id = str_replace( array( $wpdb->base_prefix, '_capabilities' ), '', $key );
    if ( ! is_numeric( $blog_id ) )
    continue;

    When I then try to log in, I get this message 4 times (which correlates to the 4 test blogs on the system - a coincidence, or repeating the search 4 times??), then I get the line...

    Warning: Cannot modify header information - headers already sent by (output started at /home/webjv/public_html/wp-includes/user.php:699) in /home/webjv/public_html/wp-includes/pluggable.php on line 866

    Any help appreciated please. I think it is a relatively simple fix and could play with parameters one at a time until I find it, but would like to approach it properly if I can.

    Any help appreciated please.

    Thank you

  • Philip John
    • DEV MAN’s Apprentice

    Okay, you're seeing that warning because you're error_reporting level is set too low or you have debugging turned on in wp-config.php

    That in turn is triggering the "Cannot modify header information" error as far as I can tell.

    Are you able to check your error_reporting level? It's a setting in php.ini, or you can override in .htaccess.

    Also check that WPDEBUG in wp-config.php is set to 'false'

    Thanks

  • ideastream
    • Flash Drive

    Season's greetings Phil,

    psek won't allow me to get to the php.ini file - they gave me the link http://web-jv.com/_pi_.php as the way to check all the settings in the php.ini file.

    According to this file, the error_reporting level is set to 6135 (not sure if this is high, low or even correct!!!!) What should it be set to please, and I can ask psek to modify?

    Have checked and confirmed WPDEBUG in wp-config.php is set to 'false'.

    Where to from here please? Would love your input please, as I'm stuck with an unuseable system (i think it's relatively minor, if I could work out what it is), and I can't move forward with anything.

    Thank you.

    Mark

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.