uptime is not working redirect loop

The uptime monitor in the hub is reporting a redirect loop https://www.screencast.com/t/wZBDtiZhA

Can this be fixed?

  • Nastia
    • Support Rock Star

    Hello Avatar

    Hope you’re doing well!

    Looks like Uptime reporting that your site is down because it is stuck in a redirect loop. I’ve visited your site and there is “ERR_TOO_MANY_REDIRECTS” error showing up. This means that Uptime works and showing a right message. Since your site is registered with us with HTTP and not with HTTPS

    Your wp-admin is loading, so please access your site’s backend, go to Settings > General, check your WordPress Address (URL) and Site Address (URL). These should be the same.

    Please note that the redirect loop showing for your site with HTTP, while HTTPS version is loading.

    If the above solution will not work, please try to force HTTPS with a plugin:

    https://wordpress.org/plugins/force-https-littlebizzy/

    https://wordpress.org/plugins/wp-force-https/

    https://wordpress.org/plugins/wp-force-ssl/

    Lets us know how it went!

    Kind regards,

    Nastia

  • Avatar
    • The Bug Hunter

    How do you mean my site is registered with HTTP? Not https?

    Note, I run a multisite WP install with mapped subdomains. So your general settings instructions can I not follow.

    I re-added my site to The Hub with https in front of the URL.

    Still the same, nevertheless the install gave me a successful install of uptime

    https://www.screencast.com/t/uKgTj6B1qct

    Can you tell me exactly what you see as HTTP? And the loop caused.

    Then I can look further into this.

    Before installing new plugins, I would like to check why you think the https seems to be the issue. Hopefully, those can be fixed in hosting.

  • Nastia
    • Support Rock Star

    Hello Avatar

    I trust you’re doing well!

    The HTTPS version of your site is working well, but if you will add in the browser’s URL your site domain name with HTTP:

    http://m.....k.com/

    The site will redirect to http://www.m….k.com/, therefore Too Many Redirect error is showing up. The HTTP version of your site should redirect to HTTPS protocol instead of http://WWW.yourdomain.com/.

    If the plugin will not fix this issue, the redirection can be set in the .htaccss file. Please temporary remove it from your host directory and see if the redirection is fixed. Please make sure to keep a backup of .htaccess file just in case.

    And if you will do any changes to the database, to change the site’s URLs, please make sure to keep a full site backup. You can create back up with the Snapshot Pro plugin.

    Let me know if you have any further questions.

    Kind regards,

    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.