Uptime keeps saying my site is down.

Uptime monitor keeps saying my site is down, tho it’s not. Currently it says my site has been down for 155 days.

we’ve tried adding the Uptime IP addresses to sucuri whitelist provided by support previously, but this still hasn’t resolved the problem.

  • Nebu John
    • Staff

    Hi Ande,

    Hope you are doing good and thank you for reaching out to us.

    Further investigating this issue I found that pings and response headers look ok and don’t seem to be blocked at all. Also, I understand that you have added the Uptime IP addresses to Sucuri whitelist.

    This issue can happen for a number of reasons but one thing that I’d recommend checking with would be server logs. There should be all the Uptime check attempts recorded and that could show if, for example, some of them were rejected by your server and for what reason. Your host should be able to help you with that.

    This is important because as Uptime requests the site every 2 minutes, it’s possible that server actually automatically starts rejecting these requests over some time – as a sort of “DDos” and similar attacks protection. I’ve seen this already done and the only way deal with it was to “loosen up” those rules by the host in server configuration or white-listing our Uptime check by the host. I’m not saying for sure that this is the culprit but it’s one of the possible causes of such issue.

    That being said, could you please consult your host and ask them about this and let me know?

    If that’s the reason, they should be able to fix that in no time but if not, we’d at least be able to rule that out in order to look for other possible causes.

    Kind Regards,

    Nebu John

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.