Uptime - missing intermediate

I have two versions on the same site on the HUB, www and non-www, however in the Uptime tab, both are reporting:
Uptime - missing intermediate

  • James Morris

    Hello Peter

    The reason you're having this issue is because http://www.YOURDOMAIN.com and YOURDOMAIN.com are actually 2 distinct identities as far as software is concerned. It's possible in DNS to have http://www.YOURDOMAIN.com be a completely different website than YOURDOMAIN.com. Most people use CNAME records to point www to YOURDOMAIN.com, but this does not automatically redirect one to the other. That has to be done in .htaccess so that only 1 version of your site is displayed.

    I just checked your site and I was able to access it via both http://www.YOURDOMAIN.com and YOURDOMAIN.com. If you've logged into WPMU DEV Dashboard using both of these domains, they will be registered separately in our system, thus the two Uptime reports.

    If you're wanting to redirect www to non-www, you can add the following to the beginning of your .htaccess file

    RewriteCond %{HTTP_HOST} ^www.your_domain.com$
    RewriteCond %{SERVER_PORT} ^443
    RewriteRule ^(.*)$ https://your_domain.com/$1 [R=301]

    If you're wanting to redirect non-www to www, you can add the following to the beginning of your .htaccess file

    RewriteCond %{HTTP_HOST} ^your_domain.com$
    RewriteCond %{SERVER_PORT} ^443
    RewriteRule ^(.*)$ https://www.your_domain.com/$1 [R=301]

    Once you've finalized your URL scheme (www or non-www) using the above, you can safely remove the unused URL from your Hub.

    I hope this clarifies a bit. Let us know if you have any further questions. We'll be happy to help! :slight_smile:

    Best regards,

    James Morris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.