[UPTIME] namecheap certificate. Cannot activate Uptime

I have two sites (live and staging).
On a live site I use a namecheap certificate.
On a staging site I use a let's encrypt.

I can active Uptimeon staging site, but not on live site.

It is definitely related to your side as I found this in performance cURL error 60: SSL certificate problem: unable to get local issuer certificate.

Also there is a second issue, when you try to acivate Uptime and you get error:
/wp-admin/admin.php?page=wphb-uptime&code=500

UX does not show any issue. So you're aware of an error but I can't see any error on the page. This is not really user-friendly.

  • Patrick Freitas

    Hi Benedikt

    Sorry to hear that you are having this problem.

    Unfortunately I wasn't able to replicate on my end this issue. I'm using the Let's Encrypt SSL and I can confirm on this is running fine on this SSL.

    However I checked ant this might be a SSL issue, you can see here:
    The certificate is not trusted in all web browsers. You may need to install an Intermediate/chain certificate to link it to a trusted root certificate. Learn more about this error. You can fix this by following Comodo's Certificate Installation Instructions for your server platform (use these instructions for InstantSSL). Pay attention to the parts about Intermediate certificates.
    https://www.sslshopper.com/ssl-checker.html#hostname=mymorize.net

    Wouldn't you mind please try to resolve this SSL issue and check if the problem is gone?

    About problem page, wouldn't you mind please to enable WordPress debug.

    By FTP access the WordPress root Folder > wp-config.php > Select and edit it, above /* That's all, stop editing! Happy blogging. */ paste the follow code:

    // Turn debugging on
    define('WP_DEBUG', true);
    
    // Tell WordPress to log everything to /wp-content/debug.log
    define('WP_DEBUG_LOG', true);
    
    // Turn off the display of error messages on your site
    define('WP_DEBUG_DISPLAY', false);
    
    // For good measure, you can also add the follow code, which will hide errors from being displayed on-screen
    @ini_set('display_errors', 0);

    Try to activate the Up-time and see if you get the page issue again, once got the page issue by FTP access the WordPress Root Folder > wp-content > find for any debug.log, change the .log to .txt and upload on the reply.

    Let me know the results.
    Have a Great Day,
    Patrick Freitas

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.