Uptime request time out

Uptime showing the site is down, and giving a "Request time out" message when activated. It's been down for the past 3 days, it was working fine before.

Please check the chat transcript for more info.

  • Nastia

    Hello Pedro Danon

    I trust you're doing well!

    I've tested your site with Website Uptime service , most of the checkpoints shown your site down with either a 408 timeout error or with 508 error. The 408 error means that the server decides to close connection with the end client (end client, in this case, is a browser that requests to load a page or an uptime service).

    Most of the times-outs happened after 30 seconds, it is a current server timeout limit for header request. Please try adding this line to the .htaccess file to set new RequestReadTimeout value:
    RequestReadTimeout header=60 body=90

    Try to ping your site again with https://www.uptrends.com/tools/uptime and see if the same timeouts will occur again. Check the Uptime from the Hub to please. Make sure to remove this line after troubleshooting is done.

    If the same issue will still persist, please check the server. error.log fie, it should provide some information about made requests and why the 408 error occurred for these request. If there is no such file, please contact your hosting provider and ask if they can enable it.

    Kind regards,
    Nastia

  • Pedro Danon

    Hi, Nastia

    I'm fine, thanks. Hope you're well too!

    I added the line and tested the site both on uptrends and the hub. I got 500 Internal Server Error from all checkpoints in uptrends and it still shows the website as down on the hub as well.

    I checked error_log, but the last entry is from 11/9 (yesterday) regarding backups from updraft plus.

    Does that change from 408/508 error to 500 tell you anything?

    Thanks for the help.

  • Dimitris

    Hello there Pedro Danon,

    hope you're doing good today! :slight_smile:

    The 500 error could have come from the edit in the .htaccess file, did you try to reverse the change and see what's happening? Please advise!

    Additionally, please do share some more access details with us. As this is public forum, you must send us your details through our safe contact form
    https://premium.wpmudev.org/contact/#i-have-a-different-question
    using this template:

    Subject: "Attn: Dimitris"

    - WordPress admin (login url/username/password)
    - FTP credentials (host/username/password/path of site in question)
    - cPanel/Plesk credentials (host/username/password)
    - link back to this thread for reference
    - any other relevant urls

    Keep in mind the subject line as ensures that it gets assigned to me.
    Warm regards,
    Dimitris

    • Pedro Danon

      Hi, Dimitris

      I just tested the website again on uptrends and it came back as available in 25 out of 41 locations. The results were as follow:

      - 25 locations available
      - 12 locations with 508 error
      - 2 locations with 507 error
      - 2 locations with 200 error

      I went back to The Hub to activate the uptime and it was also showing as up for the last 2 hours. As we didn't find out the cause, the issue might come back. I have 3 questions:

      1. But there's no point in continuating the investigation unless it does, right?
      2. If I mark as resolved, can I reopen the ticket if it comes back so we'll have this info?
      3. What can I do so this period won't mess up my reports? Is there a way for you to reset it to look as if the feature was only activated now for the first time?

      Thank you

  • Nastia

    Hello Pedro Danon

    I hope all is well!

    The errors that start with 5XXm like 508 and 507 are server related error and have nothing to with WordPress. The 200 error, however, is a successful error, indicate that all is well.

    The best thing to do is to check the error logs on your server, both the web server logs and, if available, the MySQL server logs and /var/log/messages.

    2. If I mark as resolved, can I reopen the ticket if it comes back so we'll have this info?

    Yes, feel free to reply back to this ticket if the issue will come back.

    3. What can I do so this period won't mess up my reports? Is there a way for you to reset it to look as if the feature was only activated now for the first time?

    I am afraid the Uptime log reset every 30 days automatically and there is no way to reset the stats manually. Please feel free temporary to edit the Report from the Hub and deactivate the Uptime feature until the issue is fixed.

    Let us know if you have any further questions!

    Have a good day and take care!

    Cheers,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.