URGENT: Both the subdomain and the mapped domain are showing

Hi There,

We are in trouble: When we activate Pro Sites on our network, both the subdomain and the mapped domain of all sub-sites are showing. (Like discussed here: https://premium.wpmudev.org/forums/topic/subdomain-redirected-to-domaincom#post-1176463)

But when we deactivate Pro Sites HTTPS doesn't work anymore on the front end. At the backend it still works.

We don't really need Pro Sites anymore as we changed our business model. BUT we need SSL. So please help us deactivating and removing Pro Sites so that HTTPS will work again.

What can we do?

Thanks, T.

  • Nastia
    • Support Rock Star

    Hello Tee , I hope you are well today!

    As I understood the only issue is when Pro Site is deactivated the HTTPS is not working, right?

    Please let me know how are you forcing SSL on your site? Please check the Domain Mapping settings if the "Force http/https" options are set to yes:

    If they are not, please choose "Yes" in both options and test again.

    If this will not work, would you please grant access from WPMU DEV > Support so I can have a closer look?

    Please see the detailed instructions on the link below:
    https://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    Let me know when you do!

    Cheers,
    Nastia

  • Tee
    • The Crimson Coder

    Hi Nastia,

    Thanks for your quick reply. The issue is, that SSL is not working on the MAIN URL/Site/domain. To my understanding I can't force SSL on front-end pages, as none of the sub sites is having SSL.

    Plus: We forced SSL for the main domain within Plesk. That does not work, as there must be a 301 redirect fromm HTTPS to HTTPS somewhere in the code/database. The result is that the site wasn't accessible.

    i granted you access, but please be careful with settings, as the network ist running real sites.

    Thanks, T

  • Tee
    • The Crimson Coder

    We tried the suggested settings (to force https) but without success. The result is that the site wasn't accessible.

    Thereafter we deactivate your domain mapping plugin with the result, that HTTPS is working!

    So the problem should be the domain mapping plugin causing 301 redirects from HTTPS to HTTP.

    Thanks, T

  • Nastia
    • Support Rock Star

    Hello Tee ,

    I've checked your site settings and the site within the WordPress settings are set with HTTP protocol, so HTTPS is not forced in your site.

    Please add the following to your .htaccess file to force HTTPS:

    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^example\.com [NC]
    RewriteCond %{SERVER_PORT} 80
    RewriteRule ^(.*)$ https://www.example.com/$1 [R,L]

    Replace http://www.example.com with your main domain name.

    Keep the original .httaccess file as backup, so in case something goes wrong, you can always restore it.

    Let us know how it went!

    Cheers,
    Nastia

  • Tee
    • The Crimson Coder

    Trust me, we've tried the normal stuff. Our tests are showing, that there must be something wrong with the domain mapping plugin:

    #1 domain mapping + pro site activated = HTTPS is working (pro sites not, but that is another story)
    #2 domain mapping deactivated = HTTPS is working
    #3 domain mapping activated = HTTPS is not working due to 301 redirects

    Pls help. Thanks. Tee.

  • Nastia
    • Support Rock Star

    Hello Tee,

    Would you please let us know have you checked for a conflict with another plugin? There is a possibility that another plugin might interfere with the Domain Mapping plugin. When all the plugins except the Domain Mapping are deactivated, does the SSL works?

    Also, from the Setting > Domain Mapping > Mapped Domains I see you mapped your original domain with HTTP protocol, I am just wondering how you did this since the Domain Mapping settings are not available on the main subsite.

    Would you please delete this record from there and try again?

    Please create a backup of your site before making any changes.

    Kind regards,
    Nastia

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.