URGENT diagnosing domain mapping problems

A site (http://www.directcomposer.com) trying to connect to my server/multisite is down. Here is what I've found so far:

* In domain mapping settings, site is listed as invalid health status
* IP address entered correctly with client's registrar
* connecting to my server via terminal, traceroute lists my IP address:

traceroute to directcomposer.com (50.116.48.102), 30 hops max, 60 byte packets
 1  einstein.cre8tives.org (50.116.48.102)  0.033 ms  0.013 ms  0.012 ms

* ping also shows resolution to my server

What other steps should I take to diagnose and resolve this problem?

  • Ivan
    • HummingBird

    Hey there peter_harris,

    Hope you are well and thanks for the question!

    I think the problem is that you redirect the domain to subdomain with "www" prefix.
    When I run CURl to see what is happening I can see the redirect -

    ivan@ivan-pc:~$ curl --head http://directcomposer.com
    HTTP/1.1 301 Moved Permanently
    Server: nginx
    Date: Fri, 16 Jan 2015 10:17:30 GMT
    Content-Type: text/html; charset=UTF-8
    Connection: keep-alive
    X-Pingback: http://www.directcomposer.com/xmlrpc.php
    Location: http://www.directcomposer.com/
    X-Powered-By: EasyEngine 2.0.1
    rt-Fastcgi-Cache: HIT
    Vary: Accept-Encoding
    
    ivan@ivan-pc:~$ curl --head http://www.directcomposer.com
    curl: (6) Could not resolve host: http://www.directcomposer.com
    gruio@gruio-pc:~$

    And then when I try to see the response from http://www.directcomposer.com I am geting not resolved, because the A record is not for the subdomain, but for the main one (directcomposer.com).

    ivan@ivan-pc:~$ dig directcomposer.com
    
    ; <<>> DiG 9.9.5-3ubuntu0.1-Ubuntu <<>> directcomposer.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 5184
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;directcomposer.com.		IN	A
    
    ;; ANSWER SECTION:
    directcomposer.com.	2394	IN	A	50.116.48.102
    
    ;; Query time: 1 msec
    ;; SERVER: 127.0.1.1#53(127.0.1.1)
    ;; WHEN: Fri Jan 16 12:21:33 EET 2015
    ;; MSG SIZE  rcvd: 52
    
    ivan@ivan-pc:~$ dig http://www.directcomposer.com
    
    ; <<>> DiG 9.9.5-3ubuntu0.1-Ubuntu <<>> http://www.directcomposer.com
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 61681
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    
    ;; QUESTION SECTION:
    ;www.directcomposer.com.		IN	A
    
    ;; Query time: 2 msec
    ;; SERVER: 127.0.1.1#53(127.0.1.1)
    ;; WHEN: Fri Jan 16 12:21:37 EET 2015
    ;; MSG SIZE  rcvd: 40

    As you can see there is no record set for http://www.directcomposer.com , - you can either set wildcart for this domain, or use the main one without prefixes.

    Hope this helps.

    Thanks,
    Ivan

  • peter_harris
    • Syntax Hero

    The site is now randomly working again.

    Perhaps this can be directed to a domain mapping specialist as I'm at a total loss as to why this site goes down more frequently than others.

    I also think that there needs to be more explanation as to how to handle both www and non-www versions of a domain with registrars. Because (as Ivan suggests) the problem is some kind of "redirect to www" we need to know how to properly configure for both.

    Thanks.

  • peter_harris
    • Syntax Hero

    Further notes...

    We had the www version of the domain listed in domain mapping. Invalid health status.

    Switched to non-www version and it suddenly became healthy.

    So is this the confusion here... that we're only supposed to enter the NON-WWW version of a domain name and that the plugin will take care of redirects when someone types in www?

    Thanks for the clarification...

  • Ivan
    • HummingBird

    Hey Peter,

    The main domain is working because you are having valid DNS record(without the WWW)

    You can map even subdomain, but you will need to have correct DNS for this subdomain.

    Right now you don't have correct DNS A record for the www domain, it is either because of some typo or wrong configuration, or it is just not yet propagated - sometimes it take up to 72 hours.

    The easiest way is just set up wildcart DNS record, you can check this codex page for more information - http://codex.wordpress.org/Configuring_Wildcard_Subdomains

    If you are not going to use this domain for anything else, just set up wildcart records and you should be fine once they propagate.

    Thanks,
    Ivan

  • peter_harris
    • Syntax Hero

    Ivan I'm totally confused.

    Right now you don't have correct DNS A record for the www domain

    We have TWO IDENTICAL A records for www and non-www as shown in the screenshot above. Same IP address, no typos. These were set up months ago so has nothing to do with propagation.

  • Ivan
    • HummingBird

    Hello Peter,

    Please check this links:
    http://dnscheck.pingdom.com/?domain=www.directcomposer.com
    http://dnscheck.pingdom.com/?domain=www.denkov.org

    The first one is your domain and the second is mine - it was used just for example you can test with others.

    While mine have errors, your doesn't resolve to anything.

    Different DNS panels from different providers work different - they might look fine, but wont work so the best way is to ask your hosing support to help set up wildcart DNS records, or search their knowledge database.

    Thanks,
    Ivan

  • peter_harris
    • Syntax Hero

    Wow this just gets worse and worse.

    Now I can't even access the site from my network control panel. Totally locked out. Keeps trying to redirect to the domain when I click /wp-admin/network/site-info.php?id=46

    No doubt I'm losing this client now... :slight_frown:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.