URL is not changing from mapped domain to original site so am getting ssl error

we have a site gildas.ucsc.edu and we have domain mapping set to redirect the login and administration to the original domain, gildas.sites.ucsc.edu. It appears to work on firefox but not chrome or safari. However, some people are telling me it works for them on chrome.

Sometimes it seems to work and other times it doesn't.

The problem is that because it's not switching to the original domain, we get an SSL error because we don't have a cert for every alias people need and we can't get a wildcard cert for ucsc.edu

On our dev system, it is similar but not the same: faculty-dev.ucsc.edu/wp-login.php should go to taft.sites-dev.ucsc.edu/wp-login.php and it works on chrome and firefox but not safari.

Any ideas at all?

  • Vinod Dalvi
    • WP Unicorn

    Hi @Leslie,

    I hope you are well today and thank you for your question.

    Do you mean for you and other people it's not working only on Safari browser?

    Could you please tell me which safari browser version and OS you are using?

    It seems you are using older version of Domain Mapping plugin so please also try updating Domain Mapping plugin to the latest version.

    Please advise.

    Kind Regards,
    Vinod Dalvi

  • Leslie
    • Site Builder, Child of Zeus

    No, you can test it for yourself. Using chrome, go to gildas.ucsc.edu/wp-login.php and you will get an ssl error because it's not redirecting to the original domain gildas.sites.ucsc.edu/wp-login.php. Firefox seems to work fine though. Chrome doesn't. Safari doesn't.

    We are using the second most recent version of the domain mapping plugin - we tried the most recent version on dev with no apparent change - we haven't tested it fully so we are hesitant to upgrade to it on our production systems.

  • Jack Kitterhing
    • Code Norris

    Hi there @Leslie,

    Hope you're well today! :slight_smile:

    I've just taken a look at this and it's a extremely strange issue, for me it's actually working on Safari and Chrome, but not Firefox, whereas for you it's the exact opposite.

    Can you let me know the exact browser versions and also if you are using any caching plugins or server side caching.

    Thanks!

    Kind Regards
    Jack.

  • Leslie
    • Site Builder, Child of Zeus

    Well, I finally figured out what is happening and I'm wondering if you have any suggestions. It is ALWAYS getting the error but in some cases, we've accepted the exception to the invalid certificate in our own personal browsers.

    The URL is transformed to https prior to redirecting to the original URL which means that we need a SSL certificate for any mapped domain unless you know what is going wrong or can do something with the plugin.

    So, essentially, when we go to http://gildas.ucsc.edu/wp-admin (or http://gildas.ucsc.edu/wp-login.php), it is being converted to https://gildas.ucsc.edu/... prior to redirecting to https://gildas.sites.ucsc.edu/...

    If we accept the SSL exception, it does indeed redirect to the subdomain with the valid certificate.

  • Jack Kitterhing
    • Code Norris

    Hi there @Leslie,

    Hope you're well today! :slight_smile:

    In 4.2.0.4, you can set force http or https on the admin domain, so this could be a workaround.

    For example, you force http for the admin of the other domain mapped sites which doesn't matter as your switching to the original domain and then on that you can force https, if this makes sense?

    Thanks!

    Kind Regards
    Jack.

  • wp.network
    • The Bug Hunter

    Hey @Leslie

    Your issues certainly are a bit different than mine, however, you might want to take a glance over my thread at
    https://premium.wpmudev.org/forums/topic/domain-mapping-w-https-my-scenario-2-staff-check-in
    though, fair warning, its a long one... you should probably just skip to the bottom where I have just finished some testing on Domain Mapping 4.2.0.6 and have attached a pdf of my results.

    The 4.2.0.6 release fixed some bugs I was seeing with the feature that @Jack Kitterhing mentions above

    In 4.2.0.4, you can set force http or https on the admin domain, so this could be a workaround.

    however, I see some bugs remaining, mostly with forcing http for mapped domain frontend redirects when https is forced for primary domain.

    Hopefully my testing notes, or at least the report that 4.2.0.6 may clear the way for you to try Jack's suggestion may be helpful.

    Kind Regards,
    Max

  • Leslie
    • Site Builder, Child of Zeus

    @Jack Kitterhing

    We've already got https required for the original domain admin. I'll attach our settings. This doesn't resolve our issue. We're still getting SSL error. Note that this is no longer true for gildas.ucsc.edu because we added an SSL cert for that mapped domain. I did try to force http: for front end but this didn't change anything mapped-domain/wp-admin....still redirects to https://mapped-domain/wp-admin.

    @Max - thanks - I downloaded your pdf and will check it out.

  • Jack Kitterhing
    • Code Norris

    Hi there @Leslie,

    Hope you're well today and thanks for your extreme patience on this.

    I've done some further tests and the lead developer of domain mapping has as well, it's now working for both of us in all browsers.

    It seems the actual was the SSL not being resolved for older browser versions, which browser versions are you running? We're now both running FF 33.1, the latest chrome and the latest Safari.

    Thanks!

    Kind Regards
    Jack.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.