URL to the XML Sitemap

My URL to the XML Sitemap is pulling my IP address instead of "http://championroper.com". Is there a way to switch this? It is causing conflict with google and bing to index my site.

  • DavidM
    • DEV MAN’s Mascot

    Hi dparrish,

    Hmm, the plugin should normally provide the url for you. Could you try simply using the following, substituting 'youraccount' for your server account/folder?
    /home1/youraccount/public_html/wp-content/uploads/sitemap.xml

    Thanks,
    David

  • dparrish
    • WPMU DEV Initiate

    Nope, didn't work. I still don't understand why it would even pull the IP. What file and variable is used to control, "URL to the XML Sitemap" link? I really need to get this working. Will uninstalling and re-installing fix this issue? I really want to avoid doing that because I have SEO complete on a lot of my pages and don't want to redo work that is complete. Please help.

  • DavidM
    • DEV MAN’s Mascot

    Hi dparrish,

    I'm at a bit of a loss with that, but looking back at your original post you mentioned there was a conflict with Google and Bing indexing your site. Are you sure it's related to this?

    Looking at your sitemap, I see the domain name rather than an IP. Google and Bing should see just that, no?

    Also, the following thread is that last I've heard of an IP address showing here, with some possible things to look at in the database mentioned by one of the developers:
    https://premium.wpmudev.org/forums/topic/ip-address-in-step-2-of-wizard

    -David

  • dparrish
    • WPMU DEV Initiate

    I actually found the issue in the DB. Here is what I found:

    In the wp_options table seach for your IP. Next, you will find everything in your tables with your IP address. you will notice an entry for, "wds_sitemap_options" edit this entry. You will find your IP towards the start of the option_value.

    Hope that helps.

    As for fixing my issue with Bing and Google, I have yet to test. I will post if it does not fix the issue

  • DavidM
    • DEV MAN’s Mascot

    Thanks for posting your solution for that dparrish. Really just strange though as it's not something we've been able to replicate in testing. We'll see what we can find as to what would cause that though.

    Just let us know if you encounter any further issues with the sitemap submission, etc.

    Thanks,
    David

  • Timothy
    • Chief Pigeon

    Hey dparrish.

    Glad you got this one sorted, I'm going to mark this thread as resolved for now.

    Hey gregw100.

    Did you get this one sorted, we haven't heard from you in a while so I thought I would check in to get an update.

    If you have any further questions then please feel free to respond or open a new thread. :slight_smile:

    Take care.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.