Usage with older versions of WP?

I have a client who is on a plan that has an older version of MySQL, and therefore she can't update to WP 3.2.1 -- will Membership still work on her older site?