Use premium plugins & Update versions

Hello,

I’d like to use some of yours plugins, and I wondered if I am required to install also WPMU DEV Dashboard in order to be up to date.

Thanks!

Marta