User can post ad without paying - Credits option not in user's admin sidebar

I'm using wordpress 3.2.1, BuddyPress 1.2.9, Classifieds 2.0.5 - a single install on http://www.idahofallsnow.com

Users can publish ads without ever paying, though the Credits Enabled box is checked. In the Admin panel, I have access to Credits, where I can purchase credits and complete the checkout process. However, as the Admin, I would never charge myself to run an ad - this option is there, as I imagine it should be for the Users. As the admin, I would just use the Post New Ad option which looks more like a regular blog post than the Plugin template.

1. How does the user get directed to the Credits and payment pages BEFORE being allowed to post their classified ad?

2. At what point does their user level change from the default to Classified Member? And what should their capabilities be as Classified Members? On my site, it is possible that some users would just remain default users and never attempt to buy credits for the classified ads. For those who do want to post an ad, at what point do their roles and capabilities change?

Thanks!

  • Philip John

    Hiya,

    As we haven't heard back from you we're going to assume the problem was sorted out and mark this ticket as resolved.

    If it wasn't resolved, or you have any more questions related to this thread please feel free to post them below and tick the 'Mark as Not Resolved (re-open)' box below the post area (or else we'll miss it!)

    Otherwise, thanks for using the forums, and for being a member of WPMU DEV, it's a pleasure to help you out and we look forward to being of assistance in the future.

    Thanks!

  • jloweezy

    Hi Phil,

    I've been so frustrated with this part of the project that I just walked away from it before I pulled my hair out.

    Today, I deleted the plugin entirely, downloaded the 2.0.5. version, and re-installed it. To configure it, I've gone to the lower Classifieds tab, and put in the payment information, as well as the other settings that are required.

    I see a tab where I can purchase my own credits (which does seem silly since I'm the Admin, but that's just a passing comment). I am leaving the Content Types alone, and going in to the Dashboard area. From this place, as the admin, I can Create a New Ad ( and it's set up like a regular blog post visually). when I post an ad, it looks as though it publishes, but I can't find where it publishes to. I have deleted this plugin so many times, that the pages and categories don't seem to make sense anymore, and I'm sure I've deleted something I probably needed.

    Now, when I log in from a different computer, as a user of the site, I am allowed to Create an Ad and publish it without ever being taken to the payment screen. If I Create a new Ad and place it into Draft status instead of choosing to publish, I can access it from the Saved Ads, and my options at that point are to edit, renew, or delete. When I choose to edit, and then change to Published status, click save, then there is no ad to be found.

    You can see the Active Ad (which I didn't pay for) under the members profile, but I can't access it anywhere else from the site.

    Is it possible to wipe an install COMPLETELY off a system before re-installing? Even though, I'm reinstalling it, it's obviously pulling up old data, or not starting over from a completely clean slate. I would really like to figure out how to use this plugin in the near future.