User cannot login on mapped domain

I have installed WMPU on tbreak.me
I have created a few blogs like tech.tbreak.me and souq.tbreak.me that are using the Domain Mapping Plugin and set to tech.tbreak.com and souq.tbreak.com

The problem is that none of the users can login if I have the domain mapping set. If there is no domain mapping, the user can login at tech.tbreak.me but as soon as the mapping is set, it simply doesnt work.

As suggested by someone in the forums, I have also commented the four lines in wp-config.php

// define('DOMAIN_CURRENT_SITE', 'tbreak.me' );
// define('PATH_CURRENT_SITE', '/' );
// define('SITE_ID_CURRENT_SITE', 1);
// define('BLOGID_CURRENT_SITE', '1' );

@

  • tbreak

    here we go with the DB and AUTH sections removed:

    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');

    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    define('VHOST', 'yes');
    $base = '/';
    // define('DOMAIN_CURRENT_SITE', 'tbreak.me' );
    // define('PATH_CURRENT_SITE', '/' );
    // define('SITE_ID_CURRENT_SITE', 1);
    // define('BLOGID_CURRENT_SITE', '1' );

    /**
    * WordPress Database Table prefix.
    *
    * You can have multiple installations in one database if you give each a unique
    * prefix. Only numbers, letters, and underscores please!
    */
    $table_prefix = 'wp_';

    /**
    * WordPress Localized Language, defaults to English.
    *
    * Change this to localize WordPress. A corresponding MO file for the chosen
    * language must be installed to wp-content/languages. For example, install
    * de.mo to wp-content/languages and set WPLANG to 'de' to enable German
    * language support.
    */
    define ('WPLANG', '');

    // double check $base
    if( $base == 'BASE' )
    die( 'Problem in wp-config.php - $base is set to BASE when it should be the path like "/" or "/blogs/"! Please fix it!' );

    // uncomment this to enable WP_CONTENT_DIR/sunrise.php support
    define( 'SUNRISE', 'on' );

    // uncomment to move wp-content/blogs.dir to another relative path
    // remember to change WP_CONTENT too.
    // define( "UPLOADBLOGSDIR", "fileserver" );

    // If VHOST is 'yes' uncomment and set this to a URL to redirect if a blog does not exist or is a 404 on the main blog. (Useful if signup is disabled)
    // For example, the browser will redirect to http://examples.com/ for the following: define( 'NOBLOGREDIRECT', 'http://example.com/' );
    // Set this value to %siteurl% to redirect to the root of the site
    // define( 'NOBLOGREDIRECT', '' );
    // On a directory based install you must use the theme 404 handler.

    // Location of mu-plugins
    // define( 'WPMU_PLUGIN_DIR', '' );
    // define( 'WPMU_PLUGIN_URL', '' );
    // define( 'MUPLUGINDIR', 'wp-content/mu-plugins' );

    define( "WP_USE_MULTIPLE_DB", false );

    // Disable BP Admin Bar
    define('BP_DISABLE_ADMIN_BAR', true);

    /* That's all, stop editing! Happy blogging. */

    /** WordPress absolute path to the Wordpress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(__FILE__) . '/');

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

  • Barry

    Hmmm. I was hoping to see a domain_cookie or something in there that would explain things, but it looks ok to me.

    You should comment out the NOBLOGREDIRECT define though.

    Can you try clearing all of the cookies on your browser and then try to login again. After you have tried (if you succeed or not) have a look at the cookies created and see what domain name is being used on them and let me know.

    Thanks

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.