User not subscribed to the site they created

Hi:
How can I fix the following:
1) New user registers and creates a blog successfully
2) New user activates blog link in email
3) New user tries to login to new blog and login fails
4) New user not subscribed to the blog they created

How can I enable the system to subscribe the new user?
Thanks,
Mark

  • Mason

    Hiya Mark!

    How can I enable the system to subscribe the new user?

    WordPress should be doing this by default, so something is stopping that from happening.

    Can you give us a rundown of any plugins you're using during signup (like singnup password, description, buddypress, etc) and the version of WordPress (and BuddyPress if applicable).

    Also, a good place to start is your server's error logs. That's where you get your first indicator as to what's causing the problem. If there's nothing there then we'll check some other things.

    Thanks!

  • squibm

    That's what I thought...
    Wordpress 3.1. All products installed are as-of last week. There are a lot of questions you could ask - but it's probably faster if you just look... Here is link to temporary login for Admin. Here is the link to the error log for the blog: Care Error Log. The error log does not appear to cooperate by providing any complaint into the log.
    Note... I'll pull all these links so they won't become public after we finish.
    As for specific questions... Here are the lists:

    • Buddypress with BlogsMU template / Version 1.2.5.2
    • Askimet
    • Exec-PHP
    • Multisite User Management
    • New Blog Templates
    • Print Friendly PDF
    • Quick Page Redirect
    • wptouch-pro

    MU List:

    • anti splog
    • additional privacy.php
    • blogs-directory.php
    • blogtemplates
    • mp-blog-register.php
    • update-notifications.php
  • squibm

    A bit more digging...
    I disabled the Multisite User Management plugin. No difference in behavior.

    Regardless of whether the user & blog are added from the "Add User" admin panel or from the main blog front end, "subscribe" never occurs. The new blog does not have the associated user attached in either role code path. The blog listing shows that the blog "belongs" to the user, but is not subscribed...

  • squibm

    Hi Mason:
    I was experimenting to see if I could figure out what wasn't working. I was following this path, when I had to take my son to the dentist. Sorry about leaving the dangler in bp-custom.php.
    The info in blogs-mu/header.php was a residue from a previous experiment. I had already commented out the code that triggered the error log entries.
    The patch code didn't work as far as I could tell. I've renamed the bp-custom.php file so it has no effect now. Please take another look at it.

    Mark

  • squibm

    Hi Mason:

    The info in blogs-mu/header.php was a residue from a previous experiment. I had already commented out the code that triggered the error log entries.

    mp-blog-register.php is by Aaron Edwards. The description says it provides registration options for blogs. As I recall, I installed it while I was trying to figure out how to enable self registration by users.
    I figured it might be the problem, so I temporarily relocated it. Boy was that a mistake. Now I've put it back but my whole instance is hosed and can't access any admin pages. I tried turning on debug and got 400 Kb worth of deprecation gibberish and can't seem to locate what's hosed in the mess.

    This is the last message before the instance dies:

    [08-Sep-2010 22:24:15] PHP Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'Array' was given in /home/content/36/6449236/html/care/wp-includes/plugin.php on line 395

    Mark

  • Mason

    Hiya Mark,

    Just took at the links you gave above in your second post. I've removed the active link for "temporary login for Admin". I tried to move this thread over to the Member's Private forum as having the information you've posted there is a huge security risk to your site, but bbpress is giving me grief tonight. For future reference, never post your DB password and info. never never never! :smiley:

    Ok, that being said, turning on the "debug" mode will always give you lots of gibberish and that's not to worry about. The final warning is something to look into, however.

    You could temporarily remove or replace your mu-plugins and plugins folders and see if WordPress comes back up. If you weren't very far along with this experiment, it may even be worth starting with a fresh database and fresh copy of WordPress.

    At this point, I'm not able to see what caused this problem in the first place but if we can get it stable again I'll be glad to continue helping you through this.

    Let me know.

    Thanks!

  • squibm

    Hi Mason:
    Thanks again. Did I mention how addicted I'm becoming to wpmudev? I sure appreciate your hand holding.
    The experiences prompted me to a variety of lessons, (which I didn't really want). So... I kinda changed tracks from feature quest, to getting blog back, to best configuration practices.
    I'd already come to the "start fresh" perspective, and have setup a scratch blog to rebuild the wp environment. Also, I put the db info in a file on my server so I could shut it off after you got it. It's done now.
    It sure would be nice to integrate some diagnostics. I suspect you guys have some diagnostic tools that enable you to discover stuff.
    As for moving mu-plugins, that's what took the admin site down. It didn't come back when I put it back.
    Mark