User roles are not synced or created.

Hi,

I have successfully installed the User Role Sync plugin on a master test and a sub test WordPress.

I've created users with various roles within the master site.

After syncing, users are synced on the subsite, but roles read "none".

I've read through a good amount of the forum support questions, but have found no viable answers. I don't have a multi-site, just two separate WordPress installs, with different databases. I've also disabled all additional plugins, and reinstalled/resynced with no luck.

The closest answer I've found was this one: https://premium.wpmudev.org/forums/topic/sync-users-roles-and-other-profile-content

But, the answer, which requires you to recreate roles on the sub-site, defeats the purpose of the plugin.

Any suggestions or answers?

Thanks,
Daniel

  • Rupok

    Hi Daniel,

    So sorry for the inconvenience. Actually, this plugin syncs users and default WordPress roles. But when you have custom roles with different capabilities, it doesn't sync that yet. I could see the same on my test site.

    I'm afraid, the current workaround is creating same roles with same capabilities in your subsite(s) and then sync the users.

    However, I personally think, it would be awesome if this plugin also synced custom roles with capabilities. So I'm moving this thread to our Features and Feedback section. More people liking this idea, more chances our developers will work on this and will include this feature in our future releases.

    +1 from me.

    Have a nice day. Cheers!
    Rupok