User submit the subscription and it says that "the account is not active"

When a user submit the subscription it says that the account is not active. OMG this is bad :slight_frown:

Why is this happenning? By the way even the pop up form is saying that, I receive an email like a user is being subscribed, but with empty fileds on name and email. And the test user is not being subscribed either!

P.S: 4 people already contact me to complaint about this register form issue. They think I am an scam… very upset!

  • aecnu
    • WP Unicorn

    Greetings Kenetork

    Sorry to hear that you are having issues going on there with your installation and membership, but you gave me none of the details that I need to know to even begin to make an educated guess.

    What are we working with?

    WordPress 3.5?

    MultiSite or Solo?

    Membership 3.4?

    Please advise.

    Cheers, Joe

  • Kenetork
    • The Incredible Code Injector

    Hi @aecnu

    WordPress 3.5

    Membership 3.4.1

    Solo

    You can test this on my site: http://aprenderlyx.com/register/

    Try to register on my site and you’ll see a message in spanish: Lo sentimos. Esta cuenta no está activa. wich translate Sorry. This account is not active. The user is passing throug this step and the subscribe button is not showing up! try this for yourself and let me know.

    This is like the user were already registered in the site but never happpened, besides that, the user is not getting subscribed, then I receive an email with username en email fields empty, and the user is not getting any message.

  • aecnu
    • WP Unicorn

    Greetings Kenetork,

    I believe this is due to a reported WordPress 3.5 core bug as Kim is having an issue too and I think that your host may have warning suppressed is why you are possibly not seeing them: https://premium.wpmudev.org/forums/topic/membership-error-not-able-to-access-anything#post-321968

    I recommend you roll back your installation using your backup while we await WordPress to fix the $wpdb->prepare bug as the WordPress technician acknowledged they have.

    Please advise.

    Cheers, Joe

  • aecnu
    • WP Unicorn

    Greetings Kenetork,

    Flagging the lead developer on your own without support staff direction can possibly result in undesirable consequences, please refrain from such practice.

    You should always make a full backup and be prepared to roll back into it just as WordPress itself recommends which will indeed result in fewer “emergency” type situations for the many and only affecting the few who did not heed the warning.

    WordPress 3.5 core bugs (i.e. $wpdb::prepare() error) have indeed trashed many installations and needs to be dealt with immediately as well as other core bugs:

    http://wordpress.org/support/topic/err-after-upgrade-to-35

    Hopefully they will release WordPress 3.5.1 soon but as a seasoned WordPress warrior I knew better then to update any of my installations until at least the time of the 3.5.1 release.

    This post is not meant to berate you or anything of the sort, just applying learned wisdom gained from dealing with WordPress major updates over the years like this one and ignoring the first release as always.

    Thank you for your understanding and hopefully WordPress coders will release a batch of fixes asap which will probably indeed resolve your issues … but until the time of the release of WordPress 3.5.1 I am personally sticking with WordPress 3.4.2

    Thank you for your understanding and hopefully these WP 3.5 bugs will be fixed asap.

    Cheers, Joe

  • Kenetork
    • The Incredible Code Injector

    Hi Joe, Thankyou for your answer…

    I wasn’t trying to contact developers or anything. Just letting you know about it.

    Thankyou for this lesson, I will never update that soon, I’ll be waiting and asking for stable wordpress and membership versions.

  • aecnu
    • WP Unicorn

    Greetings Kenetork,

    My apologies sir regarding the updating and there is a slight miss communication here on my part, I just had your interests in mind and as far as our plugins go you are always welcome to jump on the band wagon and let us know any issues you are having with them – please do!

    It is best for us to nip them in the bud when they are found because considering the almost infinite configuration possibilities to include hosting, it is impossible to anticipate every possible outcome.

    Detailed input from seasoned members like yourself is very valuable and welcome.

    Have a GREAT upcoming weekend!

    Cheers, Joe

  • megan_bennett
    • New Recruit

    Hi and any help appreciated with my issue. I have a registration process in place at http://www.printable-alphabets.com/register-annual/

    All was running fine for the past few months. WordPress, Jigoshop and subscriptions for annual subscriptions with Membership Module.

    Today 18/12/2012, I upgraded to WordPress Version 3.5.

    I also upgraded the Membership Module to Version 3.4.2.

    I am running and upgraded today JigoShop Version 1.4.9 to display products that are able to be purchased via a small annual subscription on the site.

    ISSUES AFTER UPGRADING

    =======================

    1. When a user attempts to register on the site to purchase a subscription, the following error occurs at http://www.printable-alphabets.com/register-annual/

    “Sorry, this account is not active.”

    2. A notification email arrives to me (the site owner), without any details of the subscriber. Fields for data in email are unpopulated. Previously an email arrived showing username and password for new subscribers.

    3. A record is created for the user in the User and Membership databases, however the subscription is not activated (no payment taken of course so that seems logical).

    4. Previously in the sign up window at http://www.printable-alphabets.com/register-annual/, the user was directed to the payment option which I use on the site – PayPal. Sign up is not presented with the option to process payment, as the above error message appears “Sorry, this account is not active.” on the sign up screen as a error message notification.

    Would be very appreciative of any help! Blitzing Christmas purchases going begging on the site. :slight_frown: People can’t register.

    Many thanks

    Megan Bennett

  • Barry
    • DEV MAN’s Mascot

    When a user attempts to register on the site to purchase a subscription, the following error occurs at http://www.printable-alphabets.com/register-annual/

    “Sorry, this account is not active.”

    Hi, yes we are aware of this issue and are trying to find and fix it for the next release, which will hopefully be very soon.

    In the meantime, can you go into the Membership options page and check the “Allow incomplete signups” box and save the update and that will get you working again.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.