User Sync not working

Hi, i need to sync two blogs one master and one subsite, the subsite is in port 8080 and it shows connected but the users dont sync.. but if i chance the port to the default 80 everything works fine, what could be the problem and how can i fix it becouse i need the subsite to work on port 8080?

  • Adam Czajczyk

    Hello Ricardo,

    I hope you're well today and thank you for your question!

    The standard port is 80 and this is the port that all the traffic goes through by default. It's not the matter of the plugin. The site on 8080 port wouldn't be directly available by it's domain (unless there's some kind of tunneling/proxy/port forwarding set right in front of it) by default and usually to access it you need to explicitly specify port number in browser like this:

    domain.com:8080

    It's the same with scripts. The way User Sync (or other parts of WordPress) connect to other sites is standard and pretty similar to what the browser does when you attempt to access the site. Therefore we need to specify the port number.

    That said, I understand that you already tried to put URL including port number in plugin configuration and that connect the site but doesn't sync users. The code is using WordPress HTTP API and I must say I'm not quite sure how to make it use non-standard port in that case.

    I have already asked one of the developers for help and am awaiting his replay. Please keep an eye on this thread for future information.

    Best regards,
    Adam

  • Ricardo

    i manage to setup the subsite in port 80 but now im getting the following error in the master site when trying to sync users.

    Warning: fopen(/homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/log/errors_m.log): failed to open stream: No such file or directory in /homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/user-sync.php on line 169

    Warning: fwrite() expects parameter 1 to be resource, boolean given in /homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/user-sync.php on line 171

    Warning: fclose() expects parameter 1 to be resource, boolean given in /homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/user-sync.php on line 172

    Warning: fopen(/homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/log/errors_m.log): failed to open stream: No such file or directory in /homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/user-sync.php on line 169

    Warning: fwrite() expects parameter 1 to be resource, boolean given in /homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/user-sync.php on line 171

    Warning: fclose() expects parameter 1 to be resource, boolean given in /homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/user-sync.php on line 172

    Warning: fopen(/homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/log/errors_m.log): failed to open stream: No such file or directory in /homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/user-sync.php on line 169

    Warning: fwrite() expects parameter 1 to be resource, boolean given in /homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/user-sync.php on line 171

    Warning: fclose() expects parameter 1 to be resource, boolean given in /homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/user-sync.php on line 172

    Warning: fopen(/homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/log/errors_m.log): failed to open stream: No such file or directory in /homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/user-sync.php on line 169

    Warning: fwrite() expects parameter 1 to be resource, boolean given in /homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/user-sync.php on line 171

    Warning: fclose() expects parameter 1 to be resource, boolean given in /homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/user-sync.php on line 172

    Warning: fopen(/homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/log/errors_m.log): failed to open stream: No such file or directory in /homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/user-sync.php on line 169

    Warning: fwrite() expects parameter 1 to be resource, boolean given in /homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/user-sync.php on line 171

    Warning: fclose() expects parameter 1 to be resource, boolean given in /homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/user-sync.php on line 172

    Warning: fopen(/homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/log/errors_m.log): failed to open stream: No such file or directory in /homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/user-sync.php on line 169

    Warning: fwrite() expects parameter 1 to be resource, boolean given in /homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/user-sync.php on line 171

    Warning: fclose() expects parameter 1 to be resource, boolean given in /homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/user-sync.php on line 172

    Warning: Cannot modify header information - headers already sent by (output started at /homepages/39/d631936095/htdocs/redfashiomi.com/wp-content/plugins/user-sync/user-sync.php:169) in /homepages/39/d631936095/htdocs/redfashiomi.com/wp-includes/pluggable.php on line 1174

  • Dimitris

    Hey there Ricardo,

    hope you're doing good and don't mind chiming in! :slight_smile:

    Could you please contact your hosting provider to double check that allow_url_fopen directive is set to ON?
    (you can also do that with a dummy file or via cPanel, check Adam's reply here https://premium.wpmudev.org/forums/topic/i-am-trying-to-use-user-sync-however-i-seem-to-be-running#post-1089467)

    Also please confirm that you have the correct file write permission inside the plugin folder (/wp-content/plugins/user-sync/) and that cron is truly enabled.

    Warm regards,
    Dimitris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.