User Synch not working and log files not created

HI there,

the synch between master and sub site is not working. I have activated the debug mode but the log file is not created after failed synch.

There was a connection problem. Please check the URL and Key of the Master site.

What to do?

  • Dimitris

    Hey there Sebastian,

    hope you're doing good and thanks for reaching us! :slight_smile:

    It seems that you haven't set the "URL of Master site" and "Key of Master site" in slave site settings here

    Could you please use the credentials found in master site here

    and hit the "Connect this site to the Master site, and do a FULL synchronization" button in slave site?


    Let me know how that goes!
    Warm regards,

  • Adam Czajczyk

    Hello Sebastian!

    I checked your site's again and I can see that connection error and that it doesn't "keep" credentials, that may however be caused by a number of reasons so we'll need to find out what they are.

    That is why I would like to ask you to add following lines to the "wp-config.php" files of both (master and sub) sites:

    define('WP_DEBUG', true);
    define('WP_DEBUG_LOG', true);
    define('WP_DEBUG_DISPLAY', false);

    These lines should be located above the "/* That's all, stop editing... */" line in both "wp-config.php" files. Once that's done, please try to run synchronization two or three times (it still won't work but it's important to try) and then for both sites

    - download the "/wp-content/debug.log" files from the server
    - rename these files (accordingly) to "debug-m.txt" and "debug-s.txt"
    - attach them to your post here.

    This should show a bit more information about what's happening "under the hood" and hopefully will help us diagnose the case and as a result find a solution.

    What's happening to the
    "Need help? Awesome 24/7 support from our WP Experts is just a question away..."

    We are still here :slight_smile: We are working round the clock 7 days a week for entire year. Please however note that sometimes we receive less questions, sometimes more. We do have families and sometimes need to sleep - though I think sleeping is much overrated :stuck_out_tongue: - so while we are doing everything that's humanly possible to help you as fast as we can, sometimes a slight delay may occur. That said, I'm sorry for keeping you waiting and I believe we'll get it to work in no time, I would however appreciate if you could credit us with some trust - I assure you we will not let you alone with this!

    That being said, please follow the steps I described above and hopefully this will let us solve the issue :slight_smile:

    Have a great day!

  • Sebastian

    Dear Adam,

    thanks for your reply. I have attached the error log files from my provider, so hopefully I don't need to edit the wp-config.php for this.

    And in regards of the delay in the support.
    I hear you. I am totally with you to acknowledge basic human needs and it is so important to take good care of ourselves. We have to accept the limitations in terms of time and energy that come with being human and I think most of us need to learn to be more in harmony with the rhythms and cycles of nature. That is so essential to our well-being, isn't it.
    However, WPMUDEV is advertising (and therefore somewhat promising) great 24/7 support and so as a customer I think it is reasonable to have certain expectations. Of course there can be times where things take longer and I understand that I am certainly not the only customer waiting for your reply, however, the last answer before your current one came on Fri Jan 20, 11:45 PM and your reply seems to be created on Mon Jan 23, 2:19 AM. This means that there was no answer for the whole weekend!
    Please note that his definitely feels too long, especially in the context of WPMUDEV saying "awesome 24/7 support".

    This does not mean that I don't appreciate your effort. I do like WPMUDEV and have mostly positive experiences with your support.

    Have a great day too!


  • Sebastian

    In addition to the logs I have some feedback from a technician at WP Engine:

    hmm that error there looks like its stemming from the code of the plugin itself, and I’m not seeing any other errors or issues with your install here. Basically its expecting a “1” , but the code is giving it a boolean instead (true or false reply). You might want to contact the developer of the plugin itself here as your database is able to be written and queryed as normal here from what I can see

  • Dimitris

    Hey there Sebastian,

    hope you're doing good today! :slight_smile:

    I just inspected the debug log files you kindly shared. There are some warning messages which are already reported in our internal bug tracker system.

    PHP Warning:  fopen(/nas/content/live/xxxxxxxxxxx/wp-content/plugins/user-sync/log/errors_m.log): failed to open stream: No such file or directory in /nas/content/live/xxxxxxxxxxx/wp-content/plugins/user-sync/user-sync.php on line 169
    PHP Warning:  fwrite() expects parameter 1 to be resource, boolean given in /nas/content/live/xxxxxxxxxxx/wp-content/plugins/user-sync/user-sync.php on line 171
    PHP Warning:  fclose() expects parameter 1 to be resource, boolean given in /nas/content/live/xxxxxxxxxxx/wp-content/plugins/user-sync/user-sync.php on line 172

    Would you please ask your host to confirm that:
    - You have file write permission inside the plugin folder. Default WordPress file permission are 644 for files, 755 for directories.
    - Check that allow_url_fopen is set to ON.

    If none of these steps make any difference, I will update our bug report with your thread/issue.

    Warm regards,