User Synchronization BP compatible?

Is User Synchronization BP compatible?
In the detials tab it says it can be used w/ WP or BP, but the but it says
"COMPATIBILITY
WordPress 3.7"
Which is it?