Users don't get registered when trying to register blog at signup

I don’t know what happened. This was working ok a few days ago. Tried switching themes and removing plugins, still an issue. I’ve read through the forums for hours, tried lots of things, still not showing up under users or getting their activation emails when signing up a blog at registration. Checked settings, “Both sites and user accounts can be registered” is on. Pulling my hair out trying to find this problem. I’m going bald.

  • Jack Kitterhing
    • Code Norris

    Hi there @julie_dreier

    I hope you are well today and thank you for your question. Sorry to hear of the problems your having.

    Please advise the following:

    Is this a sub directory or sub domain setup?

    Who is your host?

    Do you have wildcard DNS configured? (only needed if sub domain)

    Any SSL installed?

    Please advise, could you paste your .htaccess here please? Can I have a link to your site please? :slight_smile:

    Thank you! Please note I will be going offline very shortly but will be back tomorrow to continue assisting :slight_smile:

    Kind Regards

    Jack.

  • julie_dreier
    • WPMU DEV Initiate

    I am just now seeing this (thank you @timothy Bowers for the email and link!)

    And thank you @jack Kitterhing for your response.

    I do have SSL installed and I am pretty sure it is a subdomain setup. I am also almost sure I don’t have a wildcard setup, I am on the dreaded GoDaddy with this. (funny how their initals are GD)

    Here is the .htaccess

    RewriteEngine On

    RewriteBase /

    RewriteRule ^index.php$ – [L]

    # uploaded files

    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin

    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]

    RewriteCond %{REQUEST_FILENAME} -d

    RewriteRule ^ – [L]

    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]

    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*.php)$ $2 [L]

    RewriteRule . index.php [L]

    And for the record, now that you mention it…I think this recently got changed during my quest for domain mapping

  • Jack Kitterhing
    • Code Norris

    Hi there @julie_dreier

    I hope you are well today.

    Unfortunately I don’t believe this going to work with Go Daddy as a hosting provider unless you have a dedicated server?

    As on shared hosting plans Go Daddy does not allow Wildcard DNS records :slight_frown:

    Your .htaccess looks good and that should work fine.

    Would it be possible to get a link to your website please to see if you have any SSL issues?

    Thank you!

    Kind Regards

    Jack.

  • julie_dreier
    • WPMU DEV Initiate

    It changed when I changed the .htaccess file and was working on domain mapping. My domain mapping works too.

    But I do have a dedicated server, maybe that’s the difference? Or maybe they caught on to me and changed it! LOL Wouldn’t surprise me.

  • julie_dreier
    • WPMU DEV Initiate

    Shouldn’t this part say “SUBDOMAIN_INSTALL’, true” ??

    define(‘WP_DEBUG’, false);

    define( ‘SUNRISE’, ‘on’ );

    define(‘WP_ALLOW_MULTISITE’, true);

    define(‘MULTISITE’, true);

    define(‘SUBDOMAIN_INSTALL’, false);

    define(‘DOMAIN_CURRENT_SITE’, ‘socialhive.biz’:wink:;

    define(‘PATH_CURRENT_SITE’, ‘/’:wink:;

    define(‘SITE_ID_CURRENT_SITE’, 1);

    define(‘BLOG_ID_CURRENT_SITE’, 1);

    /* That’s all, stop editing! Happy blogging. */

  • julie_dreier
    • WPMU DEV Initiate

    Ok, I see it should stay false (checked wordpress.org multisite setup instructions)…ok with my dedicated IP I have set up a wildcard DNS in Godaddy.

    Says it will take about an hour, I’ll post back and let you know what happened as a lot of people don’t know they can have godaddy and wildcard settings…

    If I remember correctly, I didn’t have to pay any extra for the dedicated IP, but I did have to have them set it up.

    Regardless of if this fixes anything, I thank you both for the comments and the reminder of wildcard settings, because I had forgotten all about that.

  • julie_dreier
    • WPMU DEV Initiate

    Follow up is that I clearly am delusional from all the coding this week. I do NOT have subdomain setup as I thought. So my .htaccess file is correct now.

    To clarify, everything works fine with one exception…new users trying to get a blog at signup. If new users don’t check the “get a blog” box, everything works great and they can then create one from within the site after logging in.

    The kicker is that this is how it is working with my network settings at “Both sites and user accounts can be registered” when in fact it should allow blog signup at register signup.

    When I choose “Logged in users may register new sites” it won’t even allow users to register.

    If I cannot resolve this issue, I will simply keep it the way it is “both sites and user…” and css hide the get a blog box. I just really wanted to run a clean system for obvious reasons.

    btw, I really appreciate all the help….:slight_smile:

  • julie_dreier
    • WPMU DEV Initiate

    FOUND IT! You won’t believe this… Last week I installed Jetpack to be able to connect to wordpress.com

    Then my connection was ultra slow so I deactivated/deleted it. Yep, that was it….

    Reinstalled Jetpack and OMG…..it’s fixed. OMG….

    4 days of coffee overload and some missing hair!

    So folks, the moral of the story is….if you install Jetpack, DON’T uninstall unless you have to and definitely don’t delete it.

  • Timothy
    • Chief Pigeon

    Hey there.

    I see you’ve been busy whilst I’ve been asleep (I’m in the UK).

    So with Jetpack enabled, your wildcard for sub sites is now working with GoDaddy?

    Or is it just registration that’s now working again?

    Glad it’s now working for you, but Jetpack shouldn’t be a requirement for you.

    Take care.

  • julie_dreier
    • WPMU DEV Initiate

    Don’t know why I’m not getting emails when replies come here. I checked the box to be notified. :slight_frown:

    I’m tellin you, I think I’ve lost my mind with my site this week. And I will need some hair extensions for sure.

    So it turns out….even with Jetpack installed….it’s still an issue. I don’t know why that one test went through and now they don’t. I even reinstalled the core wp files, deactivated all the plugins/themes and used default bb theme.

    I have a wildcard setup with Godaddy successfully with a dedicated IP

    Wondering if I should delete all plugins and go from there. Maybe start new multisite? But I would have to do it on another hosting account, as it needs to be in root.

  • julie_dreier
    • WPMU DEV Initiate

    I’ve narrowed it down to Buddypress is the problem. I had deactivated every other plugin but left that one….then just now deactivated and everything worked fine. When I activate ONLY buddypress, it doesn’t work. So that has to be the problem.

    How to fix? I have attempted this once before and that is probably where I messed my site up. Gonna Google and see what this takes to do it right. I think I remember seeing a thread on here about it, but everything went crazy when I deleted the buddypress tables. (That’s when I restored the database)

  • Jack Kitterhing
    • Code Norris

    Hi there Julia, (@julie_dreier)

    I hope you are well today and thanks for the additional information.

    I think your find your points might be a bit more again :wink:

    Right as this is a BuddyPress issue, you say you deleted the tables for BuddyPress a few weeks ago, did you manually re-create these tables or did you install BuddyPress again and then they were installed?

    Could you send me some login details please to take a look at this?

    Please send through the following.

    – In the subject field add “Attn: Jack Kitterhing”

    – Link back to this thread

    – Include admin/network access

    – Include FTP

    – Include any relevant URLS for your site

    On the contact form, select “I have a different question“, this ensures it comes through and gets assigned to me.

    Contact Us

    Thank you!

    Kind Regards

    Jack.

  • julie_dreier
    • WPMU DEV Initiate

    Thank you for your reply Jack. I reinstalled everything and had a clean database and still having the same issue. However, I decided that I don’t really want people to sign up their blog at the same time they register, so I just removed that part with css. I would’ve liked to just clicked the box in settings, but as you know those aren’t working correctly. I did however, move bbpress to my main site instead of network, other than that everything was the same.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.