Users Not Showing in User List after batch create

Hello – I was able to successfully batch create all my users using your awesome plugin, but I noticed now that after doing so that either via my Site Admin or Network Admin (using WPMU) none of the users show in the list (see screenshot).

I wanted to edit some users to make them contributors and discovered that I cannot change their roles. So at first I was confused and I tried to add 'existing user' to site giving them Contributor roles but it said the user was already a member of my site, even though I can't see them in the list.

When I setup my batch create file I used the following values in my spreadsheet:

null null Username null EmailAddress Member

I'm just not sure why I'm having this error? Did I do something wrong?

  • DavidM
    • DEV MAN’s Mascot

    Hi TehStig,

    Sounds like the users got added but without a user role. I think that can still be done using Batch Create again while ensuring the file’s setup to add them with a user role.

    As you mentioned ‘null null Username null EmailAddress Member’ as your format, I’m wondering if you actually used ‘Member’ as the user role or if you used ‘contributor’?

    On that note, could you please provide an example of a line or two from the file you’re using? You can mask out the email address for security purposes, but we’d just need to see how exactly everything else looks.



  • TehStig
    • WPMU DEV Initiate

    Thanks David – after doing some research I was able to handcode the following url to get to the screens where I needed to be: wp-admin/user-edit.php?user_id=666 (where 666 is your user_id you want to edit).

    I did use the value: Member but perhaps it was the capitalization that was the culprit? There are over 1500 account emails listed and none worked not even mine until I manually assigned the role, now those people are showing up in my list.

  • Mason
    • DEV MAN’s Sidekick


    As we haven’t heard back from ya with any response in awhile I’m gonna mark this one resolved. If you’d like to go through anything further, feel free to re-open this thread. Alternately, you can also always open up a new one.


  • Vladislav
    • Dead Eye Dev


    I believe it may be the custom role that tripped this kind of behavior, one way or another. Is it an actual role on your system? I. e. are you able to create new users with this role through regular WordPress “Add user” mechanism?

    If you are, it is possible that “Member” is role’s display name, not its’ actual name. Could you please try to run a custom spreadsheet with just one user entry, following the same format as your original file – except, replace “Member” with “member”?

  • Mason
    • DEV MAN’s Sidekick


    As we haven’t heard back from you we’re going to assume the problem

    was sorted out and mark this ticket as resolved.

    If it wasn’t resolved, or you have any more questions related to this

    thread please feel free to post them below and tick the ‘Mark as Not

    Resolved (re-open)’ box below the post area (or else we’ll miss it!)

    Otherwise, thanks for using the forums, and for being a member of WPMU

    DEV, it’s a pleasure to help you out and we look forward to being of

    assistance in the future.


Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.