Users unable to request new password

Hi,

A user has come across the issue that when they try to update their password after forgetting it, they are unable to do so because the url they get sent an the email from WordPress goes to a 500 Internal Server Error page.

I have replicated this issue myself by going to the wp-login.php page, clicking the "Lost your password?" and then entered my username to request a new password. I received the email to update the password, but when I clicked the link to update it, it just goes to a 500 error. Have you come across this issue before?

The website WordPress version and plugins are fully updated.

Best Regards,
Andrew

  • Ash

    Hello Pete

    Looks like there is an error produced. Would you please enable debug mode and check if there is any error? To enable debug mode please go to wp-config.php and change

    define( 'WP_DEBUG', false );

    to

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_DISPLAY', false );
    define( 'WP_DEBUG_LOG', true );

    Now try to replicate the 500 error again. That will create a file called debug.log inside wp-content folder. Open that file, check the very bottom and you will see the latest errors. Please send me those.

    Have a nice day!

    Cheers,
    Ash

  • Pete

    Hi Ash,

    I've done this but the only error that appears is one about the that there are the maximum user connections for the database, I've pasted the most recent error lines here as it is repeated a lot for today, and censored the name of the database:

    /home/sites/bsrlm.org.uk/public_html/wp-includes/wp-db.php on line 1531
    [22-Oct-2018 02:09:30 UTC] PHP Warning: mysql_connect(): User (databasename) already has more than 'max_user_connections' active connections in /home/sites/bsrlm.org.uk/public_html/wp-includes/wp-db.php on line 1562
    [22-Oct-2018 02:30:29 UTC] PHP Warning: mysqli_real_connect(): (HY000/1203): User (databasename) already has more than 'max_user_connections' active connections in /home/sites/bsrlm.org.uk/public_html/wp-includes/wp-db.php on line 1531
    [22-Oct-2018 02:30:29 UTC] PHP Warning: mysql_connect(): User (databasename) already has more than 'max_user_connections' active connections in /home/sites/bsrlm.org.uk/public_html/wp-includes/wp-db.php on line 1562

    I don't think this error is related to users resetting their own passwords though.

    Many Thanks,
    Andrew

  • Kris Tomczyk

    Hi Pete

    Errors from debug.log mean there is a limit to the number of connection can be made to database for each user. Your installation seems to be exceeding that limit. I recommend in this case contact with your host provider to see if they can increase it for you.

    The value they should check is MAX_USER_CONNECTION.

    If this won't help would you please run a conflict test? Please deactivate all plugins and check if the problem gone. If so, then enable all plugins one by one and find which one is having conflict. If there is no positive result, switch to default WordPress theme like 2017 and see if it works.

    Kind Regards,
    Kris

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.