Use third party libraries in plugin developement?

Hi you guys! I have received notification from Wordpress.org that my submitted plugin (to the directory) gets admitted (WHOOHOO!) if I only change the calling of the images to within the plugin, and not as it is now, from a Google Drive URL (ok that was slightly cheeky).

But I really want to have them called remotely since the plugin can then also be use in mu-plugins. Now I have checked on this and it seems to me that thirdparty libraries are allowed as long as they are GPLv2 compatible. ('... All the code in the plugin must be compatible with GPLv2 or later, even if you did not write that code. Third-party libraries must also be compatible').

So my question is, am I allowed to use a third party library, should I want to, and if so can you name the one you recommend.

Thanks,

Nick