Using a Different Visual Editor for Q&A Plugin

How can I change the visual editor used by people asking/answering questions? Or is there a way to specify which parts of the visual editor can be accessed by different user levels?

I use Advanced TinyMCE. People asking questions have access to every TinyMCE plugin activated by Adv. TinyMCE. I'm worried this is a security risk because visitors can use the editor to embed flash, images and iframes etc... I'd like to either disable TinyMCE for Q&A, use a basic editor for Q&A like the one used in this forum or set role permissions different TinyMCE plugins.

Thinking about it, I would prefer to use a basic editor like the one used in this forum i.e very limited visual and no HTML editor.