Using Domain mapping. New mapped domain showing invalid health

Hi there, I mapped a new domain and it is coming back as invalid. It is pointing to the correct DNS record and I have a dedicated ip address with my multisite. I have mapped a domain before with success. The main site is https secured and when I went through the process to purchase a domain through enom using the domain mapping plugin, everything went fine except that when it was done, the address to the newly mapped site came back as https. I deleted the mapped domain and attempted to map it again just as http. It seemed to take but it is still coming back as invalid. In the settings area of the domain mapping plugin, i deselected force https and deselected both verify dns and check propogation. I am pretty confident I have all the settings configured correctly. How can I get this domain mapping to be valid and connect to the site and also how can I prevent this problem from happening on future mappings expecially when purchasing the domain from me using enom? Thanks. i granted access to site via dashboard.

  • Connectivity.Engineer
    • Design Lord, Child of Thor

    What are you using for DNS Resolvers on your server?

    I know it sounds like a funny question - however if the domain itself is NOT resolving to the local server - your site will show these kinds of errors.

    if you do have access to ssh just run this

    `less /etc/resolv.conf

    then do an nslookup against the dns servers shown and see if it lists the correct IP address.

    That should help start the debugging process ...
    if you can report back here the findings - we can then step forward a bit more...

    PS - thanks for a very clearly outlined question!!!

  • Leslie
    • The Crimson Coder

    Thanks Luis for the link. I did see that thread during my initial research on this problem and tried it but it didn't work. Also thanks to Connectivity engineer for your help too. I checked with my host and the new mapped domain does not have any dns records. I purchased the domain through my multisite using my enom account as a reseller. I would think the domain mapping plugin would take care of pointing dns records during the purchase process. Is this not true? this is my first test purchase to make sure it all works. What did I miss? Is the plugin malfunctioning or did I configure the reseller settings or the plugin incorrectly?

  • Luís
    • Support

    Hi Leslie ,

    Hope you're doing well today!

    Firstly, sorry for the extreme delay in the reply and all the problems it may have caused.

    The default DNS should be defined in the eNom account and Domain Mapping will set the DNS to this default DNS definition.

    Regarding to the HTTP/HTTPS, this is changable in the domain mapping settings page on the sub-site, simply click on the key to the left of the domain and the scheme will change.

    HTTP should be the default and I not sure if you can set the default scheme in eNom account. However, can you give us access to your admin panel, so we can check your Reseller API log?

    If you don't already know, please, follow the link below, to see how enable the staff login:

    http://premium.wpmudev.org/manuals/wpmu-dev-dashboard-enabling-staff-login/

    When you enable this option, please post again!

    Cheers, Luís

  • Leslie
    • The Crimson Coder

    It turns out that I needed to set my default ip address with enom so that it automatically pointed to the correct server ip address. thanks for everyone's help on this. Now it is automatically mapping and setting DNS records correctly using the domain mapping plugin.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.