Using GCal integration with dummy providers

I have finally gotten Gcal and Appts+ to talk together, but I'm not sure how to breach certain language barriers between them.

I (Liz) am the sole non-dummy service provider. I have 2 dummy providers, "Farmington Office" and "Kingfield Office." Each dummy provider provides the same services. I do feel that if there were a way to actually set up multiple locations within Appts+ this would be an easier process (please pass on that request!).

I'm unclear on whether I have to create new calendar/APIkey/etc for each dummy provider. Currently in my computer browser's GCal it is showing only past appointments, and when I check the user profile for my dummy providers, integration mode is set to disabled.

I just want confirmation before I do that (which has to involve my webmaster for the API key upload portion) of what end result I should be after.
I believe:
1- I will have 3 separate API keys: one for me (Liz), one for dummy provider #4 (Farmington Office) and one for dummy provider #5 Kingfield Office.
2- I can have 1 shared "Service account email address"
3- I can have 1 shared "Calendar to be used"

I don't understand how to properly enter a service into the GCal end of things and have it show up in Appts+ as a treatment linked to a provider. My experience thus far had appointments GCal had "reserved" linked to provider "our staff."

I have other questions, but for the sake of clarity I'll start with this. Thank you!

  • Elizabeth

    I just rechecked my GCal. Each dummy provider now has SOME future appointments showing up, but not all. The ones showing up have been added more recently, I'm going to try deleting and re-adding them...

    It worked to delete the ones not showing up and re-add them. After adding them back in I immediately went to GCal and refreshed the screen and they were there! So as long as it keeps working as it is right now, things should be fine with that part of the question. Thank you!

    I've also run into an issue (due to my own fault) with daylight savings time switch. When I set the time in Word Press I chose -4 for my time zone rather than a CITY in my time zone. Google calendar's setup was to have me choose my time zone by name and automatically adjusted for the time change. So the appointments I added in Appts+ after the time change (but before I realized I had set the WP time incorrectly) are showing up in GCal as starting an hour earlier. So my feedback here for others would be to make sure the WP time zone is set by CITY rather than UTC.

  • Elizabeth

    I figured out why my appointments have been disappearing from GCal! In the Reserved by GCal section I had been Confirming new appointments, and once they appeared in Active Appointments I had been removing them from Reserved by GCal. I didn't realize that they had to stay in there (I like to keep a clean and efficient list).

    Is there a way to enter appointments into GCal so that they will be labeled properly once they arrive in A+? It seems that when the GCal appointment gets to A+, I still have the job of editing the "Title" "Provider" "service" areas so they show up properly.

    If I am correct, then the rest of my question is happily resolved! Thanks for all the help!

  • pxwm

    Hi @Patrick Cohen - I hope you don't mind me making a suggestion

    Hi @Elizabeth

    If I've understood correctly when you enter an appointment through GCal it records as 'our staff' and you have to assign.

    If I'm correct then what you require is achievable but you need to setup individual Google calendars for each Service Provider.
    This can be through a single Google account or their own Google account.

    This also means you have to mirror the GCal setup process for each Service Provider and create an api for each.

    Once you have setup a Google Calendar for each Service Provider and created an api you then would need to complete the following:-

    Login to your Wordpress dashboard as Admin

    Select A+ settings
    Then Select 'Google Calendar' tab
    Then set the field 'Allow Service Providers for Google Calendar API Integration' to 'Yes'
    Then Save

    Then logout
    Then login to the Wordpress dashboard as each Service Provider using their Wordpress login details

    Then Select 'Profile' in the left hand menu

    If you then scroll down you will see a new section called 'Appointments+ Google Calendar API'

    Please Note: You have to follow the same set of instructions as you did when you populated the 'Google Calendar' that are contained in the 'Instructions' line
    Not forgetting to upload the api key

    There will be a set of fields the same as in the A+ 'Google Calendar' tab
    Set the 'Integration Mode' field
    Then populate these with the api key and the email fields
    Then Save
    Then repeat for all your Service Providers

    Please Note: Once completed you may wish to log back into your Google account and setup sharing of all the calendars so you can view all the appointments through a single calendar.
    This way if you have many Service Providers you can use the filter functionality to view all or a combination of the Service Providers appointments through a single shared calendar.
    You can then make appointments for each Service Provider and this should be populated in A+ and assign the appointment to that Service Provider without you having to make changes.

    Please Note: The only change you should have to make is to change the status from 'Reserved by GCal' to say 'Confirmed'
    Also to confirm once you change the status to 'Confirmed' the appointment can ONLY be cancelled through A+ NOT GCal.
    However if you wish to change a time/date this should be achievable through GCal.

    Testing is the same as in the main A+ 'Google Calendar' tab
    There should be a 'Test Connection' at the bottom of each Service Provider Wordpress profile page.
    Clicking on this should indciate a success message at the top.

    Once you have tested and if all as required you may not want the functionality in GCal to make appointments for 'Our Staff' as you currently do as this would eliminate anyone accidentally making an appointment for a 'no specific provider' option.
    If you wanted to achieve this then:-

    Login to your Wordpress dashboard as Admin
    Select A+ Settings
    Select 'Google Calendar' tab
    Then set the field 'Integration Mode' field to 'Integration disabled'
    You don't need to remove any the data in the other fields.

    Please Note: Make sure you keep the settings in the 'Allow Service Providers for Google Calendar API Integration' field to 'Yes'
    And in the 'Appointments will be sent to Google Calendar for' field to 'All'

    I hope this helps

    Regards
    SteveB

  • Elizabeth

    @SteveB Thanks for that suggestion! Makes sense to do it that way - I assume that only the "provider" will be assigned once the appt gets into Reserved by GCal, not the treatment. One day it would be nice for the treatment entered to coincide with A+, but I'll take what I can get!

    Still this is a great step in the right direction - especially since I finally figured out how to make these new calendars appear on my phone calendar!
    Thanks for all the help!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.