Using Protected Content without the payment gateway

Hello,

Is it possible to setup Protected Content to hide the registration page?

I'd like to use the ClickBank affiliate program to promote my products, but they require I use their payment gateway. Therefore, after a user has paid through ClickBank, I can redirect them to the Protected Content registration page, so they can create their account.

Once their account is created, they have access to the protected pages. Can I hide the registration page, since anyone who knows that url could just sign up and get the content for free?

Basically, I just need a way to provide paid users with a hidden url to register. I hope this makes sense.

Thanks,
Chris

  • Michael Bissett

    Hey @Christopher, hope you're doing well today! :slight_smile:

    While you could send users to the registration URL, protecting that URL from un-authorized access (i.e. those who haven't purchased a Clickbank product) would require custom development presently, since you're looking to have a means of allowing only authorized members (those who have purchased a Clickbank product) access to that page.

    An out of the box method that you could try though, would be to use the "Manual Gateway" inside of Protected Content, and have members sign up for your site that way. You would need to have them reach out to you with their Clickbank payment information, and check out the information sent manually before approving their memberships, but it would be an option.

    If you're wanting a more automatic solution developed (or, even better, a Clickbank gateway developed), I would advise posting on our Jobs Board about this:

    https://premium.wpmudev.org/wordpress-development/

    In the meantime though, I've moved this over to the Features & Feedback section on the forums, so that other members here can vote on this being considered for a future release. :slight_smile:

    Kind Regards,
    Michael

  • Christopher

    Hi @Michael Bissett

    Thanks for the response. I think the Manual Gateway option will work. However, I tried to set it up, but it does not seems to be working as expected.

    I activated the Manual Gateway with a message to contact me. When I test it by registering an account and entering the user details (name, email, password, etc), I get the following message:
    --------------------------------------------------------------------------------------------------------------
    Your request to join the membership was successfully received!
    The Payment Gateway could take a couple of minutes to process and return the payment status.
    --------------------------------------------------------------------------------------------------------------
    What is supposed to happen at this point? In Admin I see that the new user is created, but shouldn't they receive the message that I entered into the Manual Gateway settings? And how to I confirm then activate their access?

    Thanks,
    Chris

  • Michael Bissett

    Hey @Christopher, thanks for your patience here! :slight_smile:

    When a new user signs up, shouldn't I get some sort of notification or email so I know to log in and give them access?

    We're presently working on a bug with the signup notification emails, once those are sorted out, you should be able to see the notification emails, as long as the "Send copy to Administrator" box is checked for the email inside of:

    Protect Content -> Settings -> Automated Email Responses

    Kind Regards,
    Michael

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.