Using Snapshot with a Multisite installation

Hi,

I tried to backup a single subsite on a multisite installation, and to restore it on a different domain. However, after doing the restore on the new domain, the site and the wordpress admin all redirected to a non-existent page on the old site. When I looked into Cpanel I could see that the site had been restored as if it were a multisite subsite, rather than as a new stand-alone site.

So does this mean that Snapshot will only restore the subsite to it's orignal place within a multisite installation?

Also, is it possible to back up and restore the entire multisite installation (with all the subsites) as a single file? I know it was not originally designed to do this, but I think I came across a recent article from wpmudev, which somehow gave me the impression that this was now possible? If not, what is the best procedure for backing up and restoring the complete multisite (I have about 10 subsites)?

Thanks for your help,
Rudy Rosen

  • Predrag Dubajic

    Hey Rudy,

    Hope you're doing well today :slight_smile:

    Snapshot shouldn't cause such issues after importing to single site, could you use our contact form and send me download link to your snapshot file, I would like to do test it on my installation and check what happens?

    You can send me the link by using our contact form https://premium.wpmudev.org/contact/, select I have a different question and set subject as Attn: Predrag Dubajic, this will ensure that email gets assigned to me.
    Also, please include this thread URL in email content.

    Also, is it possible to back up and restore the entire multisite installation (with all the subsites) as a single file?

    Unfortunately this is still not possible but it is something we are working on changing in future so that entire network could be added in one file.

    Best regards,
    Predrag