Using the Parrot theme. When using your editor, if I place

Hi,
Using the Parrot theme.
When using your editor, if I place a custom CSS on the page and choose "write custom code" (not enter 3rd party code), when I enter into the HTML section the youtube video HTML:
<iframe width="1280" height="720" src="https://www.youtube.com/embed/oOlu9JAU364?rel=0" frameborder="0" allowfullscreen></iframe>

an exclamation mark in a red triangle appears, and if I click save, there is no message, but the HTML is not saved.
Any idea what is wrong with the HTML above?

I'm using the PARROT theme.

I'm trying to add a Youtube video which will be reactive and won't have the adverts at the end, or the youtube video playback options on it.

I got the code from youtube, and managed to get it to work in the "embed 3rd party code" section of custom CSS, but I'm unable to modify the CSS except globally if I use that option.

Thanks
Dave

  • Milan

    Hello @Dave Allsopp,

    Welcome to WPMU DEV.

    I hope you are having a good day and thanks for the posting. :slight_smile:

    To place third party code in upfront, you have to use "Third party Code" choice of Custom Code element. Otherwise it will not render content on page. The reason of such behaviour is because third party code and custom html code managed by upfront differently. So Meanwhile if you want to target css for your external content you need to write it globally, because at this moment there isn't any alternative choice available for this.

    I hope this helps you.

    Please let me know if there is anything else I can help you with.

    Best Regards,
    Milan Savaliya.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.