v1.0.3 requires WP 3.3?

Just to clarify. I see this in my updates:

You have version 1.0.2 installed. Update to 1.0.3.
Compatibility with WordPress 3.2.1: Unknown
Compatibility with WordPress 3.3.1: Unknown
- WP 3.3 compatibility for help dropdowns. NOT BACKWARDS COMPATIBLE

My assumption from this is that the 1.0.3 version of the plugin is only compatible with WP 3.3+. Is this correct? I'm still on 3.2.1 and will be for a little while longer, so just need to clarify.

While we're on the subject, why is it that all the WPMU DEV plug-ins I use don't seem to populate the "Compatibility with WordPress x.x" area in the updates screen when updates are available? This would be helpful.

Thank you.