Verify that snapshot is working

Hi:

I recently transferred this multisite install over to WPENGINE and have reconfigured snapshot. But I cannot get it to run. So, I figured I would ask you to see if I have configured it properly. I have configured two different snapshots, both targets are to Amazon S3.

Support access is turned on.

Thanks very much.

  • Adam Czajczyk

    Hello Nigel,

    I hope you're well today and thank you for your question!

    I've accessed your site and checked settings. The test connection to Amazon S3 went fine and your snapshots seemed to be setup fine as well. I then took a look at WP Engine's "Blog Error Log" (that's available through a WP Engine menu of your admin toolbar) and I found out that there's a non-existing database table that's blocking snapshot process.

    The table was related to Relevanssi search plugin, however I'm not sure if reference is a "leftover" in snapshot's config or in WP install but I suppose it may be related to changes in site config.

    That said, I wen't to settings pages for "Structured..." snapshot and changed the "Include all database tables..." option to "Include selected...", then selected all available tables (which are not picked up from plugin's settings but from "live" database in this case).

    After that, I switched "Backup Internval" to "Run immediate" in order to test snapshots and process went fine. Now there are archives created with current status "Destination: pending", meaning that files should be successively sent to S3.

    I set snapshot's "Backup Interval" back to as it was and next run should be around noon Dec 12th. I think we should now wait 'till then and see if it works.

    In case it still didn't work, let me know please and I'll examine error log again. We'll also have to check if WP Cron is running fine then. Hopefully though it should all be all right now :slight_smile:

    Best regards,
    Adam

  • Adam Czajczyk

    Hey Nigel!

    Thanks for your feedback.

    I've visited your site and apparently one-time switch to "selected tables" was good enough to sort the "missing db table" issue. As for now both snapshot's are set again to "All tables" and when run manually database part goes well.

    However, both snapshot's stop at some point while archiving /plugins/ folder, resulting in "time out" and server's "bad gateway" error. This of course prevents process from successful completion.

    What I did next was setting the "StructuredMarkets..." snapshot to omit all plugins but still archive all db tables, themes and other files and then scheduled it to run every five minutes. This worked. Therefore I'm sure one of the plugins must be blocking the process, though I'm not sure yet why.

    That said, could you please try following:

    1. add following lines to your wp-config.php file:

    define( 'WP_DEBUG', true );
    define( 'WP_DEBUG_LOG', true );
    define( 'WP_DEBUG_DISPLAY', false );

    2. wait a moment to make sure that that snapshot has either run successfully or has failed; it's important to be sure that it has been "fired up"

    3. look for "debug.log" file inside /wp-content/ directory of your server; it would be great if you could share it with me

    I suppose that the plugin that's blocking backup process has either some folder/files permission issues or broken files but first we need to find out which one is it.

    Best regards,
    Adam

  • Adam Czajczyk

    Hello Nigel!

    I'm sorry for the delay on my side!

    I followed the instructions but because the snapshot isn't running at all with the plugins included there's nothing in the log about it. I tried doing a manual run but as far as I can tell that didn't run either. Attached is the log file:

    The log file you attached actually suggest that the snapshot may stop on WP Engine and or our own WPMU DEV Dashboard plugins and I assume you're hosting your site on WP Engine's servers. Reference to these plugins are ending the debug file which may mean that that's where Snapshot stopped and couldn't proceed. This would correspond with our previous finding that Snapshot doesn't complete because of plugins.

    That said, I admin I'm not quite sure of how that plugin is built and if it's not including any special "security" features. It would be worth to for sure to try the following:

    1. access your site's /wp-content/mu-plugins/ folder via FTP
    2. try changing /mu-plugin/ folder and its contents permissions to 0755 (which mean read+write+execute for owner, read+execute for group and everybody else)
    3. do the same for /wp-content/plugins/wpmudev-updates/ folder
    4. fully purge (and if possible temporarily disable) WP Engine's cache via WP Engine's server management panel

    and then give it another try.

    Let me know please if this changed things!

    I don't think you would have manually created snapshots in your testing and then deleted it AND the destination.

    I haven't created any new destinations during my testing, neither did I remove any. I didn't also create/remove snapshots, just changed its settings what I described before. This again makes me turning my attention to possible server cache issues, therefore could you please give above steps a try (#4 would be even more important then) and see if it helps?

    Best regards,
    Adam

  • Nigel

    Hello - I am still continuing to try to troubleshoot this. But I think you're right - some sort of plugin is getting in the day. In the meanwhile I have found another bug - a very simple one. If you opt to do "selected files" and select "mu_plugins". The setting does not take. If you edit the snapshot, the checkbox is always unchecked no matter how many times you check it and save it.

    Also, it would be nice to get a duplicate option so we dont' have to keep specifying the same options over and over again for each sub-site. But that's an enhancement request for the next version.

    I will keep you posted on what I find.

  • Adam Czajczyk

    Hello Nigel,

    Thanks for your replay!

    As for "duplicate" option. I agree that's a fine idea that would make a handy feature. I think it would be great if you could post that separately in the "Feature Suggestions and Feedback" section of our forum.

    As for Snapshot troubleshooting. Keep me updated on your finding please and I'l investigate it further if necessary.

    Have a nice day!
    Adam

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.