Version Compatability Detail

Why is there no explanation of which versions of WP or WPMS with which older versions of a plugin are compatible?

Right now it is just guess and check? Seems odd.

I am using 3.0.1 (with good intentions of updating in the not too distant future), but need to know which version of the e-Newsletter plugin work with that.