Videos Plugin Breaks ACF Repeater Drag/Drop

The Integrated Video Tutorials plugin breaks the Advanced Custom Field Repeater Field's Drag and Drop functionality.

Apparently this is a problem that other people have experienced as well:
http://support.advancedcustomfields.com/forums/topic/repeater-field-drag-and-drop-not-working

This is happening on several different sites, and there aren't any javascript errors in my sites either.

Any idea what's causing that?

  • Kasia Swiderska
    • Support nomad

    Hello christina_hooper,

    First thing that comes to mind, that is JavaScript conflict, but if you say there is no JS errors, then the there have to be different reason.
    Unfortunately I don't have AFC PRO to test it so I would like to take a look on your site. You can grant support access via WPMU DEV > Support > Support Access > Grant Access.

    Also please enable debug mode in WordPress. To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

    define('WP_DEBUG', true);

    In order to enable the error logging to a file on the server you need to add yet one more similar line:

    define( 'WP_DEBUG_LOG', true );

    In this case the errors will be saved to a debug.log log file inside the /wp-content/directory.

    Depending on whether you want your errors to be only logged or also displayed on the screen you should also have this line there, immediately after the line mentioned above:

    define( 'WP_DEBUG_DISPLAY', false );

    The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it. I would need then to see contents of the debug.log file - if it's short you can past it here, but when is large file please paste it to the text file and attach to post.

    kind regards,
    Kasia

  • christina_hooper
    • Site Builder, Child of Zeus

    I granted you access to a development copy of the site - so you can play around with anything you need to since we're just deleting this one when you're done anyway.

    //edited credentails

    Repeater field is on this: http://squaddev.com/COS/wp-admin/post.php?post=10&action=edit
    in the Test repeater section. You should be able to click on the 1, 2, 3 on the left side of each row and drag them around, but that's not working. If you disable the videos plugin, then it works.

    //dcited credentails

  • Rupok
    • Support Ninja

    Hi christina_hooper

    I hope you had a wonderful day.

    I do apologize for the delay in response but I checked in details and I'm confirming that the drag-and-drop feature is not working in post/page edit section when "WPMU DEV Videos" is activated. However, the drag-and-drop feature is working fine in the Custom Fields creation page in plugin settings.

    So I'm reporting this as a confirmed bug and I hope our developer will fix the conflict. Please keep in mind, our developers work round the clock and they have to deal with lots of critical issues and other things. So it might take a little while for them work on this and provide the solution.

    Have a nice day. Cheers!
    Rupok

  • Aaron
    • CTO

    I wasn't able to recreate in time for the 1.5.3 release, but I made some proactive changes in hopes that it may help the situation. Let me know if 1.5.3 does not fix your issue please.

    If the conflict still exists, can you try turning off videos in contextual help in the plugin's settings. I'm almost positive that's where the conflict will be, and that will at least be a temporary solution for you.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.