Visitor role cannot be found Error Message

I recently updated my Q&A plugin and now I am receiving this error message on my dashboard:

[Q&A] Visitor role cannot be found. Try to deactivate and reactivate the plugin, if you continue to see this message, consult our Help and Support.

I did go ahead and deactivate/reactivate via my network dashboard but I am still getting the message. Any suggestions?

Thanks,

John

  • jonnylons
    • Flash Drive

    @Hakan - no, it only gives me an option for Administrator, Editor, Author, Contributor, and Subscriber. There is no option for Visitor. That must be the bug - I am using Safari, but let me check Firefox or another browser just to make sure.

    Thanks, @Timothy for following up!

  • Hakan
    • The Incredible Smush

    Hi John,

    This should be browser independent. During install or reactivation, a custom role 'visitor' should have been created, but in your case for some reason it couldn't and it cannot.

    FYI, this was also the case while you were using the plugin before. With the new version I just made this issue visible to be taken care of.

    Can I ask your wp-admin credentials for further analysis? You can send it using our contact form:
    https://premium.wpmudev.org/contact/

    Cheers,
    Hakan

  • jonnylons
    • Flash Drive

    Thanks everyone but I think I figured it out.

    I had the plugin Network Activated and it was demanding that every site on my network use it - this may have led to the error message. I went back and did a Network Deactivate and then activated it ONLY on the site I was going to use the plugin on. Much better overall.

    I didn't realize, and this may seem stupid, that I don't have to Network Activate every plugin that I intend to use. In the old days, you did, if I recall correctly. So mentioning that this is a plugin that should NOT be Network Activated may help others, too.

    In fact, it was something that I learned that also will enhance the performance of other plugins like Pro Sites!

    Now, to find a good theme to use with this plugin!!!

  • Timothy Bowers
    • Chief Pigeon

    It should work well in multisite, I've had it enabled before for testing purposes and never seen an issues with roles.

    But ya you don't have to network activate everything. Performance is also better as then it does not run on every site in a network.

    I don't recall having to network activate it in the past for everything and I'd been using WPMU since one of its first released, but it was that long ago I could be wrong. lol

    Thanks for letting us know your sorted now. :slight_smile:

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.