Visitor sent to 404 page instead of No Access Page

My 'stranger' setting is set at a level called "Visitor". My level "Visitor" has only one Negative condition stopping them from seeing one specific Page on my site.
If my visitor clicks on a link to that page they are being shown a 404 page. Even though I have a Protected Content page created and selected. I have also checked the override 404 page checkbox - both on or off it makes no difference.
I am using a WooThemes (and have a pluggable.php issue to deal with on the index page) but I have tried with the default theme as well and still get sent to the 404 page so I don't believe the theme is at fault.

I have only one page on the site that I wish protected for non-subscribers. Should I be doing this differently?
Please advise
Many thanks
JA