Visual Tab and HTML Tab default

My members keep posting to bbPress forums with <p> tags. I'm wondering if it is because they are writing in the HTML tab instead of Visual Tab. When I post something using Visual Tab it looks perfect.

Do you think this is the problem?

If so, can we make the default to be Visual Tab, possibly in functions.php of child theme?
Thank you.

  • Adam Czajczyk
    • Support Gorilla

    Hello Mary,

    I hope you're well today and thank you for your question!

    The bbPress plugin by default doesn't use/include a Visual editor and instead that's a "text mode" editor only equipped with a few formatting buttons. Therefore I suppose that you're either using an additional plugin or some custom tweak/code that's replacing default bbPress editor with full-featured WP editor. Could you please shed some light on this?

    I believe I'll be able to help you with this but I need to either replicate this setup on my site first (to examine it and find a solution) or at least take a close look at it on your site. It would be great then if you could grant me a support access. I'll not make any changes, just review bbPress and related settings in order to replicate them in my testing environment.

    Have a nice day!
    Adam

  • Mary
    • Wisp of the WP Loop

    Hi Adam,

    I was using BuddyPress Forum Editor. I have temporarily de-activated it to see if that was the plugin that was providing the Visual tab. It was.

    Perhaps I should be looking for a different WYSIWYG Editor for the forums.

    I have granted support access.

  • Mary
    • Wisp of the WP Loop

    Hi Adam,

    I was using BuddyPress Forum Editor. I have temporarily de-activated it to see if that was the plugin that was providing the Visual tab. It was.

    Perhaps I should be looking for a different WYSIWYG Editor for the forums.

    I have granted support access.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.