Want to change WordPress wording on Membership pro invoice

I'm using membership2 pro for my membership portal, I have 2 queries. 1. My visual editor, Optimize Press seems to have become unresponsive after the new update. I'm getting a blank screen or no response at all when I edit a page. 2.The invoices that members get after registering for memberships seems to come from the default wordpress mail. I want it to send from a custom email address

  • Sohag Ronjon Dey

    Hi Senor Chavez,

    Hope you are having a beautiful day! :slight_smile:

    I have gone through your site and could not regenerate the issue. I have created a draft page with Optimize Press also and that worked fine. Could you please clarify more about the issue?

    About the email setup - I assume you like to use a different email service for example gmail. Please correct me if I’m wrong. If you like to use something like gmail you can use WP Mail SMTP. I have used it with my gmail ID. You can install this plugin from your wordpress Dashboard > Plugins > Add New. On that page search with "WP Mail SMTP" and the plugin will appear with an install button. Install and activate it. You can also find more information on installing plugin from wordpress repository here

    https://premium.wpmudev.org/docs/using-wordpress/installing-wordpress-plugins/

    After installation please open the plugin settings page in your Dashboard > Settings > Email. You will find the configuration details in FAQ section of this page

    https://wordpress.org/plugins/wp-mail-smtp/

    For gmail please check the attachments.


    Hope this helps.

    Please let us know if you need any furthur help.

    Cheers,
    Sohag

  • Senor Chavez

    Hi Sohag ,

    I'm doing really good. Thank you so much for asking. I really appreciate your detailed reply! Here are my issues:

    I have gone through your site and could not regenerate the issue. I have created a draft page with Optimize Press also and that worked fine. Could you please clarify more about the issue?

    I'm not able to do any of those actions. The edit page just goes blank and when I click on the live editor in opens in a full window instead of a cascaded page. I've attached screenshots for details. I have also given support access. We are releasing very soon. So I would really appreciate a quick response.

    About the email setup - I assume you like to use a different email service for example gmail. Please correct me if I’m wrong. If you like to use something like gmail you can use WP Mail SMTP.

    Yeah! That is what I wanted to do. I do use gmail but for some reason, it does not authenticate the account (even though I have allowed less secure apps in my account info).

    What I really want is the from address from people to not be a default wordpress email. In market press there is an option to change the default email to xxxx@xxxx.com without the need to configure SMTP. It would be awesome if that could be configured. Thank you so much!

    Gowtham

  • Sohag Ronjon Dey

    Hi Gowtham,

    Thanks for your detailed reply and I hope you are having a beautiful day! :slight_smile:

    I have gone through your site and tried to regenerate the issue again and I found that the issue you are facing are actually with the pages that are created from

    Dashboard > OptimizePress > Create New Page

    When we open such a page to edit we don't see anything when the wordpress tab under the title is selected and when the "Optimizepress" tab is selected it shows the block with "Live Editor" and "Page Revisions". I think these are optimizepress's settings as the pages created from

    Dashboard > Pages > Add New

    has a tab titled "Optimizepress Settings" under the title while the pages created from Dashboard > OptimizePress > Create New Page has a tab titled "OptimizePress". Please check the attached screenshot.

    To know more about the usage of "OptimzePress" please refer to their getting started guide

    https://optimizepress.zendesk.com/hc/en-us/articles/204515168-Ultimate-Getting-Started-Guide

    The edit page just goes blank and when I click on the live editor in opens in a full window instead of a cascaded page.

    I have gone through the page. This page is getting these settings as it is created using

    OptimizePress > Create New Page

    Pages like these provide you "Live Editor" to edit the page in a full window so that you can have the same sturcture of the front end and select the various blocks of the page and add/delete/edit them. Hope this helps you. It will also be helpful to contact your theme supplier about this.

    However if you are experiencing this changes after any plugin instalation or update then will you please make a basic theme/plugin conflict test? To perform it, please follow all the steps described on a flowchart in this article (you may need to scroll the page down a little):

    https://premium.wpmudev.org/manuals/using-wpmu-dev/getting-support/

    Yeah! That is what I wanted to do. I do use gmail but for some reason, it does not authenticate the account (even though I have allowed less secure apps in my account info).

    I assume that you are using gmail's mail service for the email id used. I have not faced any issue when I tried with my gmail id. However please refer to the following page to see the options that can help you filter the default from wordpress.

    https://enriquechavez.co/change-email-sender-wordpress/

    Hope this helps.

    Please let us know if you need any further help. We are always here to help you.

    Cheers,
    Sohag

  • Lindeni Mahlalela

    Hello Gowtham,

    I hope you are doing great today. I went through your website dashboard settings. I notice that Sohag has already addressed the live editor issue above.

    I'm not able to do any of those actions. The edit page just goes blank and when I click on the live editor in opens in a full window instead of a cascaded page.

    I did some tests too and it works well on my end with Membership 2 activated or even if not activated. However, I have noticed a lot of PHP warnings in your debug logs, these warnings are about Scripts and CSS not added correctly.

    I also found the following line:
    PHP Notice: Undefined offset: 2 in /nas/content/live/stanutley/wp-content/themes/optimizePressTheme/lib/tpl/live_editor/membership.php on line 305
    Even though this seems to be a warning and may not affect the display, but this can have a great impact on the rendered page if it relies on that variable. If you are using membership module of optimizepress then this might be the cause. Unfortunately this is a problem with the theme and you may have to contact them about this.

    It would be easier for us to replicate the issue if you give us a step by step guide as to how you get to the blank page, I was able to get create 2 draft pages using both methods outlined by Shohag, only difference is that when you go to "Pages > Add new", you get the WordPress editor with the option to insert OptimizePress content short codes, it works well. Also going to "OptimizePress > Create New Page", I was able to create a new page and edit it using the Live Editor.

    If you don't mind, please give us the title of the page you are having problems with, tell us step by step what you did that resulted in the blank page so we can try to replicate. Once we have that information we will do further troubleshooting until we get to the root of this issue.

    The OptimizePress documentation has a troubleshooting guide for blank pages, please see if none of the possible causes apply to your setup: https://optimizepress.zendesk.com/hc/en-us/articles/201347596-Blank-White-Screen-on-Website-Home-Page

    There is also a wonderful guide on how to troubleshoot plugin/theme compatibility: https://optimizepress.zendesk.com/hc/en-us/articles/200553686-Incompatible-Themes-Plugins

    Please try those guides and let us know how it works out.

    Yeah! That is what I wanted to do. I do use gmail but for some reason, it does not authenticate the account (even though I have allowed less secure apps in my account info).

    Now with regards to the email not sending issue. I see the settings under "Settings > Email", the username used is not a standard gmail address and that could be the reason why you received the failed authentication error. In the settings of WP Mail SMTP plugin, you should only use valid SMTP login credentials, if you choose to use Gmail, then you must use the username and password you use to login to Gmail.

    If you are not using the standard GMail but Google Apps with your domain, then the smpt host should be that of your domain and not the standard gmail.com, if you are using regular Gmail account then you should use the username and password of that Gmail account.

    Once you have changed those, then your the plugin will be authenticated successfully.

    I hope this helps, please let us know if you are still having the same issues again.

    Enjoy the rest of your day.

    Cheers,
    Mahlamusa

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.