Warning: fopen Warning: fread() /Warning: fclose()

I installed the membership plugin. The widget shows up on wordpress theme, but i get Waring message copy bellow.

mu-plugins path "mu-plugins" ( that did not work)
I deactivated, deleted and uploaded the plugin file (membershipincludesdirectly, membership.php) in new path: "plugin" (I get same warning message)

note:
When I 1st installed the free membership lite plugin "that worked fine!
I deactivate the FREE one and deleted it.. and than installed the premium that I purchased, but I get warnings error:

Warning: fopen(/home1/mariovfx/public_html/lebanonrealstate/wp-content/plugins/membership/membership.php) [function.fopen]: failed to open stream: No such file or directory in /home1/mariovfx/public_html/lebanonrealstate/wp-includes/functions.php on line 4165

Warning: fread(): supplied argument is not a valid stream resource in /home1/mariovfx/public_html/lebanonrealstate/wp-includes/functions.php on line 4168

Warning: fclose(): supplied argument is not a valid stream resource in /home1/mariovfx/public_html/lebanonrealstate/wp-includes/functions.php on line 4171
The membership plugin version is Enabled

Member counts

User counts
Total Users 3
Deactivated Users

  • Mason
    • DEV MAN’s Sidekick

    Hiya Mario,

    First off, welcome to WPMU DEV! :smiley:

    Sorry for the trouble with these errors. I'm gonna ask a couple of our devs to come by and take a look at this with you. I've not seen this come up before with the membership plugin.

    Thanks and again, welcome!

  • Ulrich
    • The Crimson Coder

    Welcome Mario!

    Instead of uploading the plugin files "membershipincludes, membership.php" directly in your plugin directory (wp-content/plugins), upload the whole directory "membership", so you will have the directory structure: wp-content/plugins/membership/{your plugin files}.

  • mariovfx
    • New Recruit

    Hi,

    I am having an issue with membership pro

    i set the levels to new subscribed members in this case "owner"

    in the edit- owner i include Positive rules, but non shows up for the owner (subscriber)

    when I apply Negative rules it shows up for the owner when logged in.

    If I change the level of user to contributor that works as well!

    I want to be able to apply Positive rules for users from the edit panel of edit levels, but for some reason it's not working on the positive rules!

    Any idea?

  • Mason
    • DEV MAN’s Sidekick

    Hiya Mario,

    For future reference, let's open up a new thread when you have a new issue like this. It keeps things nice and clean and easier for us to address the issue for ya as well. Thanks!

    Now, are the rules you're adding for areas of the admin section of WordPress? I'm not sure how changing a member's level from subscriber to contributor would have any effect otherwise.

    If you tell us a bit more about what you're trying to accomplish I bet we can get ya the desired result.

    Thanks!

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.