Warning in my admin-area after update to 1.0.1.

Hi there,
I get a warning at http://amsyri.net/wp-admin/admin.php?page=membership2-protection
that says:
"... supplied for foreach() in /www/htdocs/w012dc3c/amsyri.net/wp-content/plugins/membership/app/controller/class-ms-controller-protection.php on line 412"
and at the settings to set protectionrules at the point where the pages of my sites should be listed It says:
"Warning: Invalid argument supplied for foreach() in /www/htdocs/w012dc3c/amsyri.net/wp-content/plugins/membership/app/helper/listtable/class-ms-helper-listtable-rule.php on line 397"

I can´t access a site per link even as membr than as admin, if I go directly to page per menue or url, then I can see it. So I tried to setup and see this error.

I granted you access to my dashboard support so you could have a look on this,
many thanks,
Richard