Warning on Dashboard when UB Dashboard widgets module enabled

I'm getting an error with the dashboard widgets module from Ultimate Branding, when enabled, I get this in the WordPress Dashboard:

Warning: Invalid argument supplied for foreach() in /home/[Edited]/wp-content/plugins/ultimate-branding/ultimate-branding-files/modules/remove-wp-dashboard-widgets.php on line 141

Ran a plugin conflict and theme conflict test and got the same issue.

Thanks in advance!

  • viobru

    Hi, Moises!

    Hope you’re doing great today :slight_smile:

    First of all, I would like to apologize for such a long delay, it seems that somehow this ticket was not correctly assigned to your profile and it got stuck at the end of the queue. Many thanks for your comprehension.

    I was trying to replicate the issue on my testing site and seems that the plugin is working ok for me, so I’m not getting any warning message. I see from the chat that you’ve already tried to re-save the settings and that, in this case, it didn’t work but that it did in other cases. So we’ll need to have a closer look at this. My teammate Jorge informed me that he has already asked you via email to send us WP admin creds, so we can work on this further. As soon as we get them we’ll continue working on this :slight_smile:

    Meanwhile, I would like to let you know that getting a warning from a plugin might not interfere with its functionality and it might just function as it should. If you want to hide this warning messages you can do so by adding this lines to the wp-config.php file:

    ini_set('display_errors','Off');
    ini_set('error_reporting', E_ALL );
    define('WP_DEBUG', false);
    define('WP_DEBUG_DISPLAY', false);

    Please check if define('WP_DEBUG', false); is already added and, if so, please remove it.
    (Keep in mind that, if you decide to add these lines, we may need to delete them for testing purposes and troubleshooting, so if you add them and find that the warning appears again it could mean that we’re currently checking the issue on your site and have deleted them).

    Looking forward to getting your WP admin creds via email.

    Have a nice day!

    Kind regards,

    Violeta

  • viobru

    Hi, Moises!

    Hope you’re doing great today :slight_smile:

    Have you used the temporary fix that I provided in the post above?

    I was going to check this again on your site but seems that support access has expired. Could you please send us an email with this?

    Subject: "Attn: Violeta" (Please use this subject line to ensure that it gets assigned to me :slight_smile: )
    - Server authentication credentials (username/password)
    - WordPress admin username
    - WordPress admin password
    - Login URL
    - FTP credentials (host/username/password)
    - Linkback to this thread for reference
    - Any other relevant URLs

    You can use our secure contact form here to send it (please, do not post this information in this thread since this is an open thread and could be accessible by anyone): https://premium.wpmudev.org/contact/#i-have-a-different-question.

    Many thanks in advance!
    Happy New Year! :slight_smile:

    Kind regards,

    Violeta

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.