Warning opening bounce test email

I've set up and configured the e-Newsletter plugin for SMTP. When I click the button Test Connection, a test email is sent to the bounce email account, but I get this warning message when the plugin tries to read it:

<b>Warning</b>: imap_open() [function.imap-open]: Couldn't open stream {pop.gmail.com:995/pop3/notls}INBOX in <b>/home/aidemocr/genglobal.org/wp-content/plugins/e-newsletter/e-newsletter.php</b> on line <b>1125</b>
Connection failed to gmail-pop.l.google.com,995: Connection timed out

We use Gmail to handle our email addressed at our domain name. I've set the POP3 server to pop.gmail.com with a port of 995, which are the same settings that work in MS Outlook. The username is the full email address and the p/w is correct.

Anyone have any suggestions on why the bounce email can't be opened by the plugin?

  • Bill Murray
    • WPMU DEV Initiate

    David, I looked at that thread and downloaded/installed the WP Mail SMTP plugin.

    I think you are right about the source of the problem, but that plugin doesn't really address it. The plugin is tied to sending mail, and I got sending mail to work without it. The problem is the authentication on READING the bounce email. I am assuming the plugin reads the email to attempt automated bounce processing?

    To get around Gmail, I set up a POP3 account on another domain I control. It doesn't require authentication to read emails. Now I am getting a different error:

    <b>Warning</b>: imap_open() [function.imap-open]: Couldn't open stream {mail.qbgarage.com:26/pop3/notls}INBOX in <b>/home/aidemocr/genglobal.org/wp-content/plugins/e-newsletter/e-newsletter.php</b> on line <b>1125</b>
    ESMTP Exim 4.69 #1 Thu, 22 Sep 2011 20:40:20 -0500

    I get that error whether I have port 26 or 110 in the port box.

    A POP3 address on one of my own servers is as vanilla as I can get. Any ideas?

  • Bill Murray
    • WPMU DEV Initiate

    Thanks for the follow up. It looks similar.

    I've spent a lot of time exploring this by studying the imap_open() function, and trying some of the suggested fixes.

    Several things...

    1) On my server config, I have allow plaintext authentication from remote clients set to Yes.

    2) I changed the plugin to hardcode the mail settings, since it was easier than updating them every time via the settings. Adding a /user=bounce parameter results in this error: SECURITY PROBLEM: insecure server advertised AUTH=PLAIN

    But adding a bounce+domain.com (the way my mailserver wants me to call the account), I get a Connection failed! error. This is further along in the plugin code, and if I'm reading it right, it suggests that mailbox was opened.

    I added the /user parameter based on this article.

    I'm curious to hear what the developer says.

  • Mason
    • DEV MAN’s Sidekick

    Just checking if it was eventually resolved in another thread? Or by yourself separately to us? Or by us over email with you? Or using our live support?

    If so, no need to reply, that's great news.

    If not, could you let us know by re-opening this topic, and we'll get onto it and helping you out asap!
    Otherwise, happy days, glad you got it sorted :slight_smile:

    Thanks!

    p.s. I've also tagged Andrey here in case you do reopen this, as they'll definitely be able to help you!

  • Bill Murray
    • WPMU DEV Initiate

    I never resolved it, and I never saw a follow up post by the developer.

    I tried a variety of email accounts, including a plain vanilla POP3 and could never get it to work. It's tough to make use of the plugin without bounce processing.

    While I'm posting, I'll also note that the opened flag for emails doesn't work for users that read an email using a webmail client, such as gmail (the only 1 I tested). The opened flag worked fine for Outlook, but as more people read emails in webmail clients, that metric isn't very accurate. There might not be a lot that can be done about that. Hopefully, it's well documented.

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.