Warning states "Your web server timeout is set very low, 60 seconds.."

Hello People,

I hope you can help me out

When I attempt to make a new snapshot, a warning appears:-

"Your web server timeout is set very low, 60 seconds. Also, it appears this timeout cannot be adjusted via the Snapshot backup process. Attempting a snapshot backup could result in a partial backup of your tables."

Yet I can not see any information on how I could rectify this, any advice would be most welcome.

Many Thanks Paul

  • Paul

    @Paul,

    Well that is going to really depend on your hosting and PHP configurations. Unfortunately advising how to correct or adjust it is beyond the scope of Snapshot since there are so many different ways a host can control this or more to the point allow you to override the server default.

    Basically, when snapshot loads it tries to update the value for the PHP settings 'max_execution_time'. If the value does not chance then snapshot reports that issue on your screen. This does not mean you cannot run a backup. Just that it there is a long running process like archiving a large media/uploads folder it may be effected by the timeout.

  • Jacob

    Hi,

    One of my clients sites is on wpengine. They have a 60 second max execution time, which is not changeable. I updated the segment size to go down to 100, and it still times out.

    The only way I know it times out is by looking at the logs seeing the DB table with 891/1904 complete, then stopping.

    We have 1024M WP_MEMORY_LIMIT and 1024M WP_MAX_MEMORY_LIMIT. Snapshot seems to think the "Max Execution Time" is 3600, even though, server-wide, it's only 60.

    Trying to go down to segment size of 50 to see where it lands now.

    Any thoughts on what to do?

Thank NAME, for their help.

Let NAME know exactly why they deserved these points.

Gift a custom amount of points.